HTTPS enabled causes resend message on Firefox

I narrowed it down to HTTPS filtering. With it on I get the message shown in the screenshot. With it off the page loads normally (no message). It doesn't happen in Chrome either way. It only started after AdGuard updated to version 3.0.297. It doesn't happen on every site, but enough to be a pain. Here is the site in the screenshot: https://searchengineland.com/google-apologizes-for-relnext-prev-mixup-314494/amp Is this a known issue?

EDIT - Running stock Pixel 3 XL on Android 9.
 

Attachments

Last edited:
M

myMoon

Guest
@BobbyPhoenix

Hello!

Try to clear the cache and reinstall the certificate (AdGuard - Settings - Network - HTTPS filtering - Install certificate to Firefox)
 
@BobbyPhoenix

Hello!

Try to clear the cache and reinstall the certificate (AdGuard - Settings - Network - HTTPS filtering - Install certificate to Firefox)
Clearing cache didn't work, and when I tried to reinstall the cert in Firefox, it said "This certificate is already installed as a certificate authority.". I looked for a way to uninstall it from Firefox to be able to reinstall it, but I can't find that option. Is there a way to uninstall it from Firefox without completely clearing Firefox's data? I did an online search, and that seems to be the only way. I have it very customized, and would lose all my settings/themes/add-ons.
 
M

myMoon

Guest
@BobbyPhoenix

To do that you just need to open system settings in the search bar type Trusted credentials - User store - find all AdGuard certs and delete them, after it's done go back to AdGuard - Settings - Network - HTTPS filtering - Install certificate and install a certificate in Firefox.
 
It did the same thing. I uninstalled it from Android, went through enabling HTTPS, installed again, but when I went to install in Firefox, it said it's already there. I opened Firefox, and still have the same issue. I guess I have to delete Firefox's data, and try again. Unless you have another way to try?
 
So I didn't really want to uninstall/clear my Firefox data, and lose all my stuff, so I decided to try another version of Firefox, so I downloaded the Beta version. I was able to install a new certificate into it since it was basically a fresh install of Firefox just like clearing the Stable version would have been if I cleared data, and then I tried browsing the site, and I still get the pop-up about the resend, so it's not the certificate causing it. Something else with HTTPS filtering is doing it.

EDIT - Are you not getting the pop-up like I am on the site I provided with HTTPS enabled using Firefox?
 
M

myMoon

Guest
@BobbyPhoenix

No, Firefox works as it should with enabled AdGuard. Can you export your settings from the Adguard - Settings - three dots (right top corner) - export settings - send it to me via PM)
 
M

myMoon

Guest
@BobbyPhoenix

Hello!

As for now, the new version has been released - 3.0.303. Can you go to the settings (system) - security - trusted credentials - user store - delete all AdGuard certificates. Then install the latest AdGuard Nightly (3.0.303) - settings - network - HTTPS filtering - Install certificate - Install certificate (Firefox)?
 
@BobbyPhoenix

Hello!

As for now, the new version has been released - 3.0.303. Can you go to the settings (system) - security - trusted credentials - user store - delete all AdGuard certificates. Then install the latest AdGuard Nightly (3.0.303) - settings - network - HTTPS filtering - Install certificate - Install certificate (Firefox)?
Thanks for the suggestion, but still get it after doing everything you said. :-(
 
Quick update. I completely uninstalled AdGuard (settings and all), and downloaded a fresh copy of the stable version (since beta was still giving me the issue). The only thing I did was enable HTTPS. After installing the cert into Firefox I tried the site, and still have the issue. I thought maybe it was some other setting I changed, but since it was all on default, the only thing causing it is HTTPS. If I disable it I can view the site no issue. Again it only started happening in version 3, and only on Firefox.
 
M

myMoon

Guest
So it's related to Firefox I guess, what's the version of FF? Can you synchronize your account (firefox) and re-install it?
 
So it's related to Firefox I guess, what's the version of FF? Can you synchronize your account (firefox) and re-install it?
Yep just Firefox. I did clear everything. I tried a fresh install of AdGuard (3.xxx) and Firefox (66.0.2 and 67). The only change I did was enable HTTPS. As soon as I enable HTTPS, and installed certs, the issue happens.
 
Another quick update. I decided to try another phone running Android 7.1.1 (Moto E4 Plus). This one wasn't used in a while, so it still had an older version of AdGuard. I updated Firefox to 66.0.2, and tried the site. No issue. Updated AdGuard to 3.0.297. Didn't touch anything else. Tried the site. Issue now is on this phone too. I thought maybe it was just the Pixel, or maybe Android 9, but now it's the identical issue on both phones. :(
 
M

myMoon

Guest
@BobbyPhoenix

Still can't reproduce this even with other phones, can you please describe the steps to reach the issue or make a short clip.
 
@TheHasagi The issue is not on all sites. If you try to reproduce it make sure you are using the link in the first post here. I know you asked for my settings (which I sent via PM), so if you want to reproduce it like I did on another phone just import my settings, and then try the link, and you should get the pop-up for resend. Turn off HTTPS, stop/close Firefox, open Firefox, try again, and you won't get it. Turn HTTPS back on, stop/close Firefox, open Firefox, try again, and you get it again. I can reproduce it every time on both phones.
 
M

myMoon

Guest
@BobbyPhoenix

Still no luck, everything works fine. If you disable "Filter websites with an Extended Validation (EV) Certificate"?
 
Top