HTTPS filtering when using proxy mode

gustms

New Member
Hello there,

Is there any way to enable AdGuard v6 beta to filter HTTPS traffic as well, when used in proxy mode, instead of "automatic filter application traffic"? The reason I ask this is because I prefer to use proxy mode as using automatic causes adguard to have a high cpu usage (~10%) when downloading something through FlashFXP and Free Download Manager (and probably other download software as well).

In my tests, AdGuard filtering is disabled in ssl enabled sites when used in proxy mode, is that how it is supposed to be? Both with WFP driver enabled and disabled.

Thanks in advance.
 

avatar

Administrator
Staff member
Administrator
Hi!

It is possible but a bit complicated.

You can do the following:
1. Install a CCProxy or something like that
2. Add it to Adguard's Browsers/Filtered Apps list (Browsers - for AG 5.10 and "Filtered Apps" for AG 6.0)
3. Disable filtering for every other process
4. Set up your browser to use the CCProxy

Or you can simply wait for AG 6.0 release. We plan to change the way we bypass the traffic of the processes we don't filter - it should help.
 

gustms

New Member
Thank you for the tip. I'm using AG 6 beta, but still get the cpu usage when downloading. Maybe it's something that will be added to future betas?

Thanks a lot in advance.
 

avatar

Administrator
Staff member
Administrator
Thank you for the tip. I'm using AG 6 beta, but still get the cpu usage when downloading. Maybe it's something that will be added to future betas?

Thanks a lot in advance.
Yep, it's planned for future betas, in the current the situation is the same as in AG 5.10.
 
Top