If ever quality needed control....


Beta Tester
I'm beginning to lose the will to live with this forum, after years of relatively painless beta testing i run into the following issues:




... which, after jumping through hoops and investigation by myself i end up with...


We keep an eye on progress with all mentioned issues.

Thank you for your efforts in resolving the problem.

Let us know if you have some other questions.

Sincerely yours,
AdGuard Support Team
Probably not a big deal given some of the other more substantial issues AG has had to deal with over the years but this was in response to the following and has left me wondering why I bothered to push the issues in the first place.


This is where I'm at, whether this can be seen as progress or not i don't know... i suspect and hope it might be:

I'm not sure if you're aware or not so i'll clarify this now, i currently have three ongoing issues with Adguard posted on the Forum:

1. BSOD with adgnetworktdidrv.sys
2. Adguard 6.3 breaking my internet connection.
3. Adguard 6.3 causing YouTube videos to crash.

Note: ALL three above are specific to Internet Explorer 11 on Windows 7 x64.

The above said, i've had time to play around with Adguard today and thanks to the way your software is now configured i could at least roll back to [a non-beta] version of 6.2 to see if it made any difference.... because bullet point 1 &2 above can't be replicated at will it remains to be seen if my findings today will make any difference regarding those issues.

With regards to YouTube videos, rolling back to version 6.2 didn't make any difference (i.e not with the default settings), however when i enabled the WFP driver it was like night and day... suddenly YouTube played videos as they should.

All the above was tested by removing Adguard via control panel (including settings), followed by a reboot, install 6.2.437.2171 (the latest available on your earlier link), reboot, disable silent updates, test, etc.

I was surprised that enabling the now default "off" setting for WFP Network Driver worked for issue '3' because when i ran into other issues previously i was always advised to disable it. indeed (and i could be wrong?) i got the distinct impression you were trying to move away from WFP?

Anyways, i'm going to leave the 'Network > Use WFP network driver' enabled for the time being to see if it solves the other issues.

I hope that helps.
<thinking aloud>
AdGuard used to be simple and did what it said on the tin, I'm not so sure it is any more.

Posted as my opinion only.