Interferences with Mac Mail IMAP accounts and site loading issues

Alhelor

New Member
I love AdGuard for Mac, but there have been two issues that have been ruining my experience for a while.

Short summary:

Issue 1:
IMAP mail accounts in Mac Mail randomly stop working (all go offline).

Trying to reconnect gives the error “Connection to [...] on default ports timed out”.
There are two ways to fix:
a. Disable and re-enable protection in AdGuard for Mac
b. Restart Mac Mail

Issue 2: Certain websites on Safari don't load fully and just "hang in there" until they are reloaded.

One site where it happens very often is news.google.com with a logged-in account, but can happen on pretty much any web page with many elements. Reloading, either by clicking the link bar and pressing Enter, or using the reload button, instantly fixes it.

Bonus issue: Rarely and very irregularly, when visiting YouTube in Safari, it says that no account is logged in, despite never logging out.

On top, it says "Sign in". Clicking on videos or browsing YouTube doesn't change it, either. Trying to upvote or comment on a video also leads to the "Please log in" alert. However, reloading the page by pressing the reload button fixes it. The account is suddenly logged in.

If these issues were fixed, AdBlock for Mac would be perfect for my usage. Please tell me what I can do to help you solve these issues. You have my full cooperation.

Below, I added some additional info for you.

----- More detailed information ------

General:
- MacBook Pro (16-inch, 2021), Apple M1 Max, running macOS Monterey (12.5); these issues have been happening ever since I got the MacBook with 12.1.
- Whenever AdGuard for Mac was uninstalled for testing, the advanced method was used.
- All these issues appear in all current and recent versions (release, beta, nightly) since at least December 2021.

Issue 1:
- It only affects IMAP accounts. Microsoft Exchange accounts continue working in Mac Mail and are not affected by this bug.
- It happens especially often after waking the Mac from sleep. However, it can happen randomly, while the Mac is running, as well. Just much less often.
- It never happens when AdGuard for Mac protection is off. It's not necessary to completely quit the AdGuard for Mac application.
- Mac Mail settings do not affect it. The bug is not related to the "Protect Mail Activity" or "Hide IP Address" features.
- network.extension.monterey.force.split.tunnel does not affect this issue.

Issue 2:
- When a website in Safari hangs and AdGuard for Mac is (globally) turned off during the hanging, the site instantly loads/ finishes loading.
- AdGuard for Safari does not cause this issue. Only AdGuard for Mac.

Bonus issue:
- Obviously, webcache and cookies have been cleared many times for testing purposes. It did not affect the issue. Eventually, the same bug would happen again.
 
Last edited:

mono39

New Member
I have similar problems. The Facebook News Feed no longer loads many elements on the page. I also see the problem with mail.
 
Top