Internet speed with AdGuard desktop app

Hobbes

New Member
I've put a similar message in Android forum, but as far as this issue is more annoying (for me) in Windows, I think it should be put here.

Several months ago, muy internet speed drops dramatically. Firs I blame my connection (ADSL line very far for company switch center), but after the installation of a fiber optic line, the speed remains very, very low, and with constan blockings. After some test, I realise that the problem is the AdGuard desktop application, if I switch off the app, I have a good internet speed.

I've tried with DNS filtering, without it, over-Quick, standard... everything. It seems to work fine several minutes (if so) and back to the slow speeds and blockings. As I said, all of this began several months (and AdGuard versions) ago.

It's there any problem with the desktop App (now in 7.9.1), filtering algorithms, or similar?

Can anyone give me a clue about what is happening? Because for me it's almost impossible to surf the web with AdGuard App on/activated.
 

Ad Slayer

New Member
When you notice the Internet is slow, do you also notice AdGuard using a lot of CPU resources in the task manager? Could you leave AdGuard on, but with all rules unchecked? This is to observe if the speed is better when Adguard doesn't parse anything. The normal behavior is having web pages load a little faster with AdGuard on. Please let us know.
 

Hobbes

New Member
Not sure how much it's a lot, but in a quick check, AdGuard uses 4-5 % of CPU with peaks of 10-12 %. Not know if it's high, normal or low. Beside that, it seems that there is no any improvement with all rules unchecked, only when I turn the protection off. Anyway I did only some quick tests, I will keep checking both.

By the way, two days ago I disabled AdGuard Assistant in my browser (Yandex) and now the situation is better (not as fast as without AdGuard, but not bad at all).
 

Ad Slayer

New Member
This CPU usage is rather normal.
OK, let's see if any other user can give us an insight so that you can use AdGuard seamlessly.
 

decker

New Member
I've put a similar message in Android forum, but as far as this issue is more annoying (for me) in Windows, I think it should be put here.

Several months ago, muy internet speed drops dramatically. Firs I blame my connection (ADSL line very far for company switch center), but after the installation of a fiber optic line, the speed remains very, very low, and with constant blockings. After some tests, I realised that the problem is the AdGuard desktop application, if I switch off the app, I have a good internet speed.

I've tried with DNS filtering, without it, over-Quick, standard... everything. It seems to work fine for several minutes (if so) and back to the slow speeds and blockings. As I said, all of this began several months (and AdGuard versions) ago.

It's there any problem with the desktop App (now in 7.9.1), filtering algorithms, or similar?

Can anyone give me a clue about what is happening? Because for me it's almost impossible to surf the web with AdGuard App on/activated.
Adguard does not impact CPU usage all that much. What you should be looking at are the results of speed tests, run with and without adguard. I dumped AG as the impact on internet thruput is severe, with drops of 50% and more. As someone mentioned this has been known for years, and I suppose the dev team does nothing is because most users are too dumb to realize that their slow internet is being caused by a program that--while doing a great job filtering ads--destroys interest speed.
 
Top