IT's doesn't working in mobile data.

KJI

New Member
Hi. I used AdGuard for Android.
When I used this app in Wifi, It's working. But, I used the mobile data(LG U+,Republic of Korea), It's doesn't work. Why doesn't working in mobile data? I usually used mobile data. So I want to know how can I fix this problem. thanks.

p.s. When I used this app ver 2.11, It still working. But I upgraded this app, then it's doesn't working.
If I could downgrade, how can I do this?
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
Open AdGuard - Settings - Advanced - Low-level settings - pref.vpn.disable.reconfigure should be checked.
 

Azzz

New Member
I'm also having this problem. when wifi on, it blocks the ads, but with mobile network, it doesn't filter any ads.

"pref.vpn.disable.reconfigure" is already enabled.

what should I do to resolve this issue?
 

Azzz

New Member
@Azzz

Hello!

What's the AdGuard version? HTTPS filtration is on?
@TheHasagi

adguard android 2.12.247
I've been using adguard for over 2 years without this issues and recently I got this new phone. seems it hasn't worked with mobile data since then.
It's android 8 and yes, https filtering is on.

not sure if it matters but I also use a korean mobile telecom. but not u+, mine is skt.

Edit: I found people using SKT as a mobile carrier have the same problem and some said checking "pref.vpn.ipv6.disable" fixed it.
However this fix is not working for me so I left a comment on adguard github. Please check it out.
https://github.com/AdguardTeam/AdguardForAndroid/issues/425
 
Last edited:

Azzz

New Member
@Azzz

That's a kinda weird thing, can you try with a new nightly build?
yep. Like you said and according to Dodegun's reply on github, the fix not working since v2.12.233, and it's working on a nightly build.
So it's sorted out for me after installing a nightly build and checking pref.vpn.ipv6.disable.

Thank you :D
 
Top