[KIS 2015 Incompatibility?] Secure Connection Failed Msg

Magoo

Beta Tester
Getting this quite often and intermitently on most https sites.

Win 7 x64
Firefox 37.0.1

Adguard 5.10
Firefox Extension 2.05

I have installed and res-installed the Firefox Certificate, which didn't change or help anything.

Deleted all the files from C:\ProgramData\Adguard\NetworkTemp\SSL except for the adguard CA.cer and adguard CA.pvk

Tried the newer network driver.

Only Filters in use are adguard assistant, adguard popup blocker, and WOT

Right now the program is unusable unless a disable https scanning or just disable it completely.

Error Msg in Firefox when trying to connect to https://kb.adguard.com/index.php?

da035c8dad32039a5053b8342a4d27ce.png

Anyone care to help? :)
 
Last edited by a moderator:

vasily_bagirov

Administrator
Staff member
Administrator
Are you sure you have restarted browser after adding certificates? Please get sure all browser processes have stopped, and then launch it again.
 

Boo Berry

Moderator + Beta Tester
Moderator
I actually guessed that correctly. Are you using the WFP driver? I just personally tested KIS 2015 with the WFP driver and it causes these issues in web browsers. Looks like it's an incompatibility with KIS 2015 and Adguard (again... this is what, at least the third time?!?). KIS 2015 does work fine with the TDI driver - just make sure Use WFP network driver under Adguard's options > Settings > Network section is unchecked.
 

Magoo

Beta Tester
Use WFP Network Driver is unchecked, I did try the WFP driver but it seemed to make things worse.
 

Boo Berry

Moderator + Beta Tester
Moderator
Odd. I'm using the latest KIS 2015 right now with the latest Adguard beta and its working fine with the TDI driver. Hmmm, maybe there's more incompatibilities there - need to test that more. Nonetheless, the issue with the WFP is painfully easy to reproduce so the dev team should have no issues reproducing it.
 

Boo Berry

Moderator + Beta Tester
Moderator
Check the latest Adguard for Windows beta topic in the beta tester's section. I've been posting my findings there. No doubt in my mind it's an incompatibility with KIS 2015 and Adguard.
 

vasily_bagirov

Administrator
Staff member
Administrator
Odd. I'm using the latest KIS 2015 right now with the latest Adguard beta and its working fine with the TDI driver. Hmmm, maybe there's more incompatibilities there - need to test that more. Nonetheless, the issue with the WFP is painfully easy to reproduce so the dev team should have no issues reproducing it.
It will definitely be tested today, I'll post any results here.
 

GodGibson

New Member
It will definitely be tested today, I'll post any results here.
I have also started getting this regularly with Norton Security 2015 with firefox 37.1

These problems are only in Firefox.

Internet Explorer , Google Chrome and Opera do not get these issues.

I have already submitted a bug report on this issue so im hoping it gets resolved.

If I disable adguard the issue no longer happens so its definitely the SSL certificate getting invalidated

BETA version does not fix this issue either.

I would be happy to assist in fixing this issue as its getting annoying for me having to disable adguard.

ERROR.png


Thank you :)
 
Last edited by a moderator:
Top