local proxy not working on S9 android 9

Discussion in 'Technical Support (AdGuard for Android)' started by menhammer, Mar 14, 2019.

  1. menhammer

    menhammer New Member

    Joined:
    Mar 14, 2019
    Messages:
    4
    I run S9 android 9 (rooted), when i use the local proxy filtering (firefox) i have major drop downs and wifi/4g connection problems (no browsing is possible also apps like ebay or amazon cant show images/text anymore), i need a restart to get my phone working again but than after a 20 min of use its stucked again. With the local vpn option no problems.
    Before on android 8 no problems at all with the local proxy method.

    Hope there will be a solution/update quick
     
  2. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,405
    @menhammer

    Hello!

    What about DNS filtering (enabled/disabled)? And if so what's the primary DNS server is - AdGuard/Google/Cloudflare (and the server-type DoH/DoT/Crypt/Regular)?
     
  3. menhammer

    menhammer New Member

    Joined:
    Mar 14, 2019
    Messages:
    4
    Thanks for your reply, will test it immediately and let you know
     
  4. menhammer

    menhammer New Member

    Joined:
    Mar 14, 2019
    Messages:
    4
    Did some testing, I turned on the DNS filtering (with local proxy) tried the adquard/google and cloudfare dns, it fixed the connection drops while i was surfing/online but when the phone was standby for a hour and picked it up again the (internet connection wifi and 4g) was gone again... when switched the dns toggle in adguard it was working again..

    Now on local vpn no problems at all, but i wish i could go on local proxy.

    Samsung s9
    Android pie/ samsung one ui
    Root
    Magisk 18.1
    firefox
     
  5. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,405
    Go to AdGuard - Settings - Advanced - Low-level settings - find pref.proxy.disable.reconfigure and try to toggle it to true/false and check.
     
  6. menhammer

    menhammer New Member

    Joined:
    Mar 14, 2019
    Messages:
    4
    Thanks for your reply, will test it now