Local VPN breaks sites...


New Member
I'm using Adguard for Android 2.11 with Android Oreo 8.1 on a Nexus 6P. Everything is fully updated.

The issue is this: when Adguard is set to use Local VPN, most sites don't load. When Adguard is set to use Proxy (rooted), everything loads fine. As an example, Google's built-in speedtest (https://www.google.com/search?q=speedtest&oq=speedtest&aqs=chrome..69i57.5572j0j7&client=ms-android-google&sourceid=chrome-mobile&ie=UTF-8) will not connect at all when using the Local VPN and eventually gives me a timeout. When I switch to Proxy mode, it works perfectly and accurately reports my connection speed.

Since the only change I'm making is switching Adguard from VPN to Proxy, I assume the bug must exist somewhere within Adguard. I'm not sure how to debug it. Thanks.


New Member
No it's Adguard-specific. When going through my Private Internet Access VPN on Android, the pages load fine. It's something in Adguard VPN but not Adguard Proxy or a different company's VPN.


New Member
Okay. I turned on debug logging, went to the site listed above (the Google speedtest site), let it fail so you could see what was happening, then sent the logs. The Helpdesk ID is: 1888843.


New Member
Here's a cut and paste:

Thank you for contacting us. This is an automated response confirming the receipt of your ticket. Our team will get back to you as soon as possible.

**User ID**: 1888843
**Subject**: [PREMIUM] [Adguard for Android] Bug report

Your personal helpdesk ID is: 1888843. Use it to identify your ticket when addressing our staff members outside of this conversation, without having to reveal your e-mail.

These links might help you to take a different approach to the problem:
https://kb.adguard.com/en - our knowledgebase which contains articles about many typical problems;
https://forum.adguard.com/index.php - Adguard forum, where you can find a thread about a similar problem or start a new one;

You can also reach us by phone at +1 844 907 4466.

Kind regards,

Adguard Support Team


Staff member
@mobamoba all is good, somehow I managed to get to a different ticket by copypasting your ID. Weird. You'll get a reply either here or via support soon.
Sorry to add to this but have encountered the same & then some. Been experiencexperiencing difficulty for a little over a week & was watching for an update. Did find in another thread link to upgrade to 2.11.81 which while being an update did not fix anything. Tried to send Bug Report & was only able to send AFTER chose Other category. Got user id so could find exactly how to record for technical support.
The following take's place after update to 2.11.81 & collected User IDID :
**User ID**: 1772154
In the attached log (hopefully I did this correct) I did turn off my AV 1st. Then @ 9:10 PM tried to open website on whitelist with Adguard VPN running & HTTPS protected.
9:11 same sight no VPN. 9:11:30 turned HTTPS off. 9:12-9:13 on Adguard Base page try Update Manually & get error about unable to do. Wait for it to timeout as lock's screen. 9:14 try update manually no VPN & successful completion.
With mobile alone or in combination with Wi-Fi the VPN can & will block Adguard itself from functioning on Samsung Galaxy A5 (2017) running Nougat 7.0.
*Just in case am attaching both recording's (1 was sent when was assigned ID) so that can be sure I recorded the event.




@Lorne Wolf MacKenzie


Check your mailbox, our support team already answered your question.

Adding a website to the whitelist stops the work of our application on such website, thus ads will not be blocked there.

The enabled HTTPS option with the maximum protection gives the best blocking ability.

The results may vary on the usage of mobile data or Wi-Fi. Moreover, while using Wi-Fi the additional DNS settings of the router may be used and may affect the results.