MMS blocked when connected to wifi

Discussion in 'Technical Support (AdGuard for Android)' started by korin, Feb 14, 2017.

Tags:
  1. korin

    korin New Member

    Joined:
    Feb 14, 2017
    Messages:
    4
    I can't send or receive MMS (group or picture messages) on Android when connected to a WiFi network with Adguard protection enabled using the HTTP proxy. It seems like this has been an issue for years, but I can't find a solution. This thread from 2015 discusses it at length, but no solution is provided: https://forum.adguard.com/index.php?threads/mms-messages-blocked.2470

    When I have Adguard enabled in HTTP proxy mode, outbound MMS messages sit in "Sending" state until they eventually time out. Inbound MMS messages generate an alert that the message was not downloaded. If I either disable Adguard protection or disconnect from WiFi, the messages will complete. SMS is not affected.

    I have a rooted Nexus 5X on AT&T, running Android 6.0.1, cyanogenmod version 13.0-20161222
    I'm using the stock messenger app from google, com.google.android.apps.messaging, version 2.0.770
    Adguard version 2.8.76

    I have added my APN MMSC domain "mmsc.mobile.att.net" to the whitelist, as well as the MMS proxy, "proxy.mobile.att.net". I've tried changing my MMS port to 8080 but it doesn't seem to make any difference.

    This problem doesn't seem to occur when I use the VPN proxy mode, but I would like to connect to my own VPN for secure communication and this isn't possible when using the Adguard VPN proxy.

    Tried searching the forum for other threads, but the system won't allow me to search on "MMS"
     
    Last edited: Feb 14, 2017
  2. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,903
    @korin have you tried enabling pref.vpn.ipv6.bypass in low-level Adguard settings? This has a chance to solve the problem.
     
  3. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,140
    @vasily_bagirov I see you haven't read it thoroughly enough. The issue happens in HTTP Proxy mode only, pref.vpn has nothing to do with it.

    @korin could you please collect a full log for us to analyze?

    Here is the instruction:
    https://kb.adguard.com/index.php?/K.../collecting-a-full-log-on-adguard-for-android

    Are you using Proxy+Automatic setup? It is quite important as otherwise VPN will ignore Adguard's proxy.
     
  4. korin

    korin New Member

    Joined:
    Feb 14, 2017
    Messages:
    4
    Hi, that's correct, enabling pref.vpn.ipv6.bypass had no effect. I'll collect and upload a log shortly. Yes, I am using automatic setup
     
  5. korin

    korin New Member

    Joined:
    Feb 14, 2017
    Messages:
    4
    Okay, I just sent the logs.
    **User ID**: 1506331
    **Subject**: [Adguard for Android] Bug report
     
    Last edited: Feb 17, 2017
  6. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,140
    Filed a bug report, thank you:
    https://github.com/AdguardTeam/AdguardForAndroid/issues/1058

    The log is pretty interesting, it looks that AG for some reason fails to connect to the proxy.mobile.att.net domain. I wonder why. Anyway, temporary solution would be to disable Adguard for the "Android OS" in the "Apps Management" settings. Meanwhile, we'll look for a better solution.
     
  7. korin

    korin New Member

    Joined:
    Feb 14, 2017
    Messages:
    4
    Thanks for the suggestion. I disabled protection for "Android OS" and it seems to work around the issue.
    By the way, the search function under Application Management doesn't find the "Android OS" application and I couldn't find a way to sort the list by name, so I had to search for it manually.
     
  8. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,140
    Btw, the issue should be resolved in Adguard's beta version. Could you please try it? You can do it by switching update channel in Adguard's advanced settings.

    That's a bug, thank you for reporting it!
    https://github.com/AdguardTeam/AdguardForAndroid/issues/1114