Never Seen or Heard Of Before, but Not Reporting Stats to App

Discussion in 'Technical Support (AdGuard for Android)' started by Esky, Oct 26, 2017.

  1. Esky

    Esky New Member

    Joined:
    Oct 26, 2017
    Messages:
    1
    Had common problems since the new version with added DNS settings. The usual reset of the app was enough to fix the timeouts, cpu hogging, etc. Updated to the newest build and issues were more frequent. Backed up the app, uninstalled it completely, and then installed it all over again and now see it's not reporting stats, counters state 0 ads, 0mb etc. Settings and Updates worked, and Androids VPN notification client showed data being filtered with Adguard, so I kept using until I turned off Adguards icon within app settings and can't turn it back on. Says it's on, but isn't.

    Turns out, something is seriously broken. Just can't tell where. The logs indicate startup, rules, intents, self checks all good. Last thing loaded com.adguard.filter.proxy.ssl.d - trusted authorities, then I pretty much get this type of error virtually on repeat taking up half the entire log:

    04:40:23.654 [pool-3-thread-30] WARN com.adguard.filter.proxy.a - TCP id=1000044 Client has closed connection without sending data. Connection info=com.sec.android.app.sbrowser /172.x.x.x:yy /104.x.x.x:443 10217

    It would do self restarts and back to that on a loop until it changes to:

    05:16:07.467 [pool-3-thread-183] WARN com.adguard.filter.html.a - Cannot write data to the output stream: sendto failed: EPIPE (Broken pipe)

    Then it'll occasionally add an 'Internal TLS error' and maybe being an attack. Reduced the log frequency of those errors once I changed the icon back to 'off' in settings. Also noticed that I can't disable protection using the green button. It'll say 'disabled', but the button doesn't grey out, neither does the Android VPN notification icon . I have to use that to disconnect androids VPN.

    I later realized that when I tried the green button, I would see the logs change up a little, like changing the handling service and a few checks, but also saw this:

    20:20:35.838 [pool-3-thread-31] WARN com.adguard.android.c.j - Cannot find package info for the installed package: com.sec.enterprise.knox.shareddevice.keyguard
    20:20:35.862 [pool-3-thread-31] WARN com.adguard.android.c.j - Cannot find package info for the installed package: com.samsung.knox.kss
    20:20:35.906 [pool-3-thread-31] WARN com.adguard.android.c.j - Cannot find package info for the installed package: com.sec.knox.containeragent2

    Another strange thing, the adguard dns site does indicate I'm using correct adguard dns servers when enabled, and not using when VPN is off. Dns checks will still show the default dns's given from my router regardless if protection is on or off. Before, a certain site/browser would should a combination of mine and adguards server.


    Lastly, noticed many of these near the end of the log:

    com.adguard.android.ServiceManager - Protection cannot be stopped. Current protection status is STOPPED

    Could be before I forced android to stop the VPN service, I'd always attempt to first try the app to disable normally. This Samsung has never been rooted, Knox counter still never tripped, not disabled either, and running MM 6.0.1. No crazy apps with admin enabled, or a security/speedboosting apps potentially interfering. Both the other VPN apps work just fine for me, Adguards the only one acting strange. When I uninstall, reboot, then reinstall it. It somehow retains all settings, like it never got uninstalled. Didn't pop up to add certificates when enabling https filtering. Any one else experience the app itself acting this way? Or does anyone here know what is possibly going on with my phone? Cleared cache partition in recovery, still no luck. Just installed it fresh since again, and it loads up like new but then it's pretty much the same except dns and http needs to be turned on. I selected random filters and switched up some options before I uninstalled it too... So weird.
     
  2. zebrum

    zebrum Administrator Staff Member Administrator

    Joined:
    Nov 21, 2016
    Messages:
    502