No filteruing since upgrade to v7.0

FSMcas

New Member
So - no more ad blocking for me. After updating AdGuard to v7, the small AdGuard symbol is not shown in Chrome anymore and no ads are blocked. First I've quit Chrome and reinstalled the extensions via AdGuard UI, then I rebooted my computer - no effect. No ads blocked. What to do now?

I've tried the latest nioghtly, no success either.
 

Boo Berry

Moderator + Beta Tester
Moderator
Is it specific websites where ad blocking fails + the icon (AdGuard Assistant) doesn't show? Or is it all websites? What Windows OS are you using and what antivirus/antimalware software are you using, if any?
 

FSMcas

New Member
Hi,

all websites. The icon in the lower corner of all websites does not appear anywhere, blocking fails compeltely (in Chrome. Have not tested other browsers, but it always worked with Chrome).

Win10 x64
Sophos antivirus
 

Boo Berry

Moderator + Beta Tester
Moderator
Does it work if you disable the WFP driver? AG Settings > Network and uncheck Use WFP network driver? You may have to reboot after changing this setting for it to take effect. Alternatively, you can also try right clicking on the AG icon next to the clock in the system tray > Advanced > Advanced settings... and check the Use redirect driver mode option and save and try that.

To me it sounds like an antivirus incompatibility.
 

FSMcas

New Member
Does it work if you disable the WFP driver? AG Settings > Network and uncheck Use WFP network driver? .
This works somehow. First, thank you! Then again, it does not fully solve my problem. Ads get filtered now without the WFP driver enabled. Great! Still, the AdGuard Assistant is not active in Chrome and my user filters are not used.
 

Boo Berry

Moderator + Beta Tester
Moderator
Yeah, sounds like antivirus incompatibility to me. Did you try the other Use redirect driver mode option to see if it helps any?
 

FSMcas

New Member
Yeah, sounds like antivirus incompatibility to me. Did you try the other Use redirect driver mode option to see if it helps any?
I've tried and I lose my connection completely... :/

Is there any way I can check what user scripts are active in Chrome and can I install AdGuard Assistant manually, just to check?
 

Boo Berry

Moderator + Beta Tester
Moderator
Likely not needed, as if I have to guess this likely an antivirus incompatibility with Sophos antivirus. @TheHasagi is going to check it out, it looks like.
 

MarkTN

New Member
Having the same problems. Must be Sophos--- which is pretty much locked down by the organization, and I'm unable to make changes. Software uninstall/reinstall, certificate refreshes (and removing FF cert, then re-installing cert), and driver redirect brought no joy. I've sent a support request via AdGuard, so hopefully something in the log files will point them to a solution. In the meantime, I'm back to using 6.4
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
@MarkTN
Hello Mark.
You can send logs to me by private message, I'll check what could be the problem.
 

Aranud

New Member
Hi,

Same problem, No filter since last update, i write to support with log and screenshot without answer...
**User ID**: 1937965

I use sophos Home too.

Thank you
 

FSMcas

New Member
Okay, I've solved it.

The problem is Sophos Web Filter. No need to fully disable Sophos (which would of course be not an option), but simply go into services.msc and disable Sophos Web Filter and the Assistant appears again, filtering works.


Still, this is just a workaround and I'd be happy if the developers could look into this to make AdGuard and Sophos fully compatible.
 

Boo Berry

Moderator + Beta Tester
Moderator
Okay, here's an idea from @avatar in the Telegram chat...

Go to AG's Settings > General Settings and scroll down to the bottom and click on Advanced Settings. From there scroll down again and uncheck/disable Use localhost for injections and Save and see if it works then.
 

MarkTN

New Member
Can confirm that this is working in my environment (Organization-administered Sophos EndPoint; Chrome Stable; FireFox Beta)

Is the primary downside of turning localhost off for injections page load time?
 
Last edited:

Boo Berry

Moderator + Beta Tester
Moderator
Is the primary downside of turning localhost off for injections page load time?
Not really. When I did my own testing, the speed was more-or-less the same either way. Does page loading seem fast to you with that option disabled?

A year or so ago AG for Windows was changed to automatically disable the use localhost for injections option if Sophos was being used on the system. Looks like there's been Sophos updates which 'broke' the disabling of it so it looks like it'll need to be updated. :)
 

FSMcas

New Member
Okay, here's an idea from @avatar in the Telegram chat...

Go to AG's Settings > General Settings and scroll down to the bottom and click on Advanced Settings. From there scroll down again and uncheck/disable Use localhost for injections and Save and see if it works then.
Confirmed working for me as well.
 
Top