not compatible with palemoon

Accel

Beta Tester
hello , i want to report that firefox extension is not compatible with the latest palemoon 25.6
 
Top