Odd behaviour chrome & ff

Nameless

Beta Tester
Ok so because im having issues with chrome randomly freezing the computer im trying out firefox and something i have noticed is that in chrome google ads are blocked but in firefox they are not :/ Same goes for gmail chrome no ads firefox ads, its as if the code is not being injected.

http://i.imgur.com/OMSaWyx.png
 

Nameless

Beta Tester
Thanks Boo Berry, will check it out when i boot up the computer and edit this post.

---Update---
So far its sorted, but it was already installed o_O

Will post if reappears.
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
If certificate was not installed you would see the "Certificate not trusted" error page.

So the issue is that for some reason connection was not filtered by Adguard.
Don't understand why yet -- need more details on how to reproduce it.
 

Nameless

Beta Tester
Might of been an error on my end here is what i rememebr

Installed chrome
Got an error about certificate not trusted on every page i tried to visit so maybe i clicked ignore???
Most pages were filtered but google was always unfiltered.
 

avatar

Administrator
Staff member
Administrator
Ah, I forgot, there is a workaround we use for FF. If certificate is not installed -- Adguard does not filter https in FF.
 

streetwolf

Beta Tester
I get the same certificate messages when I create a new profile for Fx via the profile manager and then run Fx with that profile.

STR:

1. I create an Fx shortcut with the -p parameter added to the command line.

2. In the Profile Manager I create a new profile.

3. Make sure you untick the run automatically at startup box.

Thereafter, running Fx and selecting my new profile will cause the certificate messages. Happens everytime for me.
 

avatar

Administrator
Staff member
Administrator
It's ok, we cannot hook on such event as profile creation.

Adguard will install certificate if you:
1. Close Firefox
2. Restart Adguard
3. Wait 30 seconds
 

Boo Berry

Moderator + Beta Tester
Moderator
Yep, same here. But I've gotten used to manually importing the certificate when doing a clean profile.
 
Top