Odd behaviour chrome & ff

Discussion in 'Technical Support (AdGuard for Windows)' started by Nameless, May 12, 2014.

  1. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    731
    Ok so because im having issues with chrome randomly freezing the computer im trying out firefox and something i have noticed is that in chrome google ads are blocked but in firefox they are not :/ Same goes for gmail chrome no ads firefox ads, its as if the code is not being injected.

    http://i.imgur.com/OMSaWyx.png
     
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,145
  3. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    731
    Thanks Boo Berry, will check it out when i boot up the computer and edit this post.

    ---Update---
    So far its sorted, but it was already installed o_O

    Will post if reappears.
     
    Last edited by a moderator: May 12, 2014
  4. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,145
    Yep, rebooting will usually solve that too!
     
  5. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    731
    I had rebooted a few times, turned the machine off and even gone bed it was as if it was ignoring the certificate on some sites like google, others it was active.
     
  6. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,866
    If certificate was not installed you would see the "Certificate not trusted" error page.

    So the issue is that for some reason connection was not filtered by Adguard.
    Don't understand why yet -- need more details on how to reproduce it.
     
  7. Nameless

    Nameless Beta Tester

    Joined:
    Mar 19, 2014
    Messages:
    731
    Might of been an error on my end here is what i rememebr

    Installed chrome
    Got an error about certificate not trusted on every page i tried to visit so maybe i clicked ignore???
    Most pages were filtered but google was always unfiltered.
     
  8. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,866
    Ah, I forgot, there is a workaround we use for FF. If certificate is not installed -- Adguard does not filter https in FF.
     
  9. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    I get the same certificate messages when I create a new profile for Fx via the profile manager and then run Fx with that profile.

    STR:

    1. I create an Fx shortcut with the -p parameter added to the command line.

    2. In the Profile Manager I create a new profile.

    3. Make sure you untick the run automatically at startup box.

    Thereafter, running Fx and selecting my new profile will cause the certificate messages. Happens everytime for me.
     
  10. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,866
    It's ok, we cannot hook on such event as profile creation.

    Adguard will install certificate if you:
    1. Close Firefox
    2. Restart Adguard
    3. Wait 30 seconds
     
  11. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,145
    Yep, same here. But I've gotten used to manually importing the certificate when doing a clean profile.
     
  12. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    Is this a bug and will be fixed? Never had this problem with AM.
     
  13. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    12,866
    It is a bug that could not be fixed at all:(
    AM cannot filter https, that's why you've never had this problem.