[Outdated] Microsoft Edge and the Windows 10 Creators Update

Status
Not open for further replies.

Boo Berry

Moderator + Beta Tester
Moderator
If you've upgraded to the Windows 10 Creators Update and you're using Microsoft Edge and you've experienced the issue where Edge is just a white screen when AdGuard for Windows is enabled, there's a quick and simple fix!

Fix: Disabling TCP Fast Open in Microsoft Edge


Step 1: Disable AdGuard for Windows.

Step 2: Open Microsoft Edge, then type about:flags into the address bar then press Enter.

Step 3: Scroll down the list until you see the option Enable TCP Fast Open.

Step 4: If Enable TCP Fast Open is checked, uncheck it!

Step 5: Close Microsoft Edge and re-enable AdGuard for Windows then finally retest Edge - it should work just fine now!

And that should do it. The root of the issue is a bug Microsoft has to fix (it's been reported). AdGuard for Windows normally should disable TCP Fast Open automatically, but reports coming in are saying it's not being automatically disabled for the Creators Update. The developers are looking into this!
 
  • Like
Reactions: Jim

spinedoc777

Beta Tester
Wow THANK YOU!! This issue was driving me nuts. I installed the creators update on 4 different PC's and had this issue only in Edge and could not find the solution anywhere. After 2 days and realizing adguard was the common element in all the PC's I came here and saw the solution.

BTW what is TCP Fast Open? Are we losing anything by disabling it?
 

Boo Berry

Moderator + Beta Tester
Moderator
https://en.wikipedia.org/wiki/TCP_Fast_Open

IMO, I've never noticed a real difference with it enabled, however the option seems to be buggy in Edge. Before the Creators Update the bug would cause an instant BSOD when opening Edge, so opening it and having it fail without a BSOD is an improvement, but it's still buggy. @avatar has reported the issue to the Microsoft developers, so hopefully they fix it soon.
 

Jim

New Member
I experienced a similar issue on a MS Surface Pro 3 and a Toshiba laptop when I installed the W10 Creators update; a large proportion of my Favorites refused to load and after a (somewhat) fruitless call to MS and going through the reinstallation process AGAIN, I stumbled upon the issue by temporarily disabling AdGuard. I subsequently uninstalled AdGuard and then reinstalled it (after also verifying that TCP Fast Open was not enabled - on my Surface Pro 3 it was not, but on the Toshiba it was - go figure?) and everything seems to operate as it should once again.
 
Last edited:

AnthonyB

Beta Tester
TCP Fast Open is kinda important.. Are there plans to get this compatibility issue (or whatever it is) resolved?

In short, TCP Fast Open speeds up a lot of the underlying communications for web pages and apps.
From Google's own engineers back in 2011 [source];
Based on traffic analysis and network emulation, we show that TCP Fast Open would decrease HTTP transaction network latency by 15% and whole-page load time over 10% on average, and in some cases up to 40%
The specification was published as RFC 7413 in December 2014 and is supposed by Chrome, Firefox, Edge, OSX, iOS, FreeBSD, etc. [source]

Microsoft have also published on it [Building a faster and more secure web with TCP Fast Open, TLS False Start, and TLS 1.3]
 

Boo Berry

Moderator + Beta Tester
Moderator
I believe @avatar found a temporary workaround for the issue, but ultimately it's up to Microsoft to fix the underlying issue.
 

Boo Berry

Moderator + Beta Tester
Moderator
It's not landed in the 6.2 beta builds yet, but @avatar found a workaround to the issue and implemented it.

I wouldn't say the issue is 'fixed' (as only MS can fix the actual issue) but Adguard for Windows 6.2 will have a workaround for it. :)

I'll unsticky/close this topic once Adguard for Windows 6.2 (with the workaround) lands in the stable channel.
 

Boo Berry

Moderator + Beta Tester
Moderator
You'd be correct. Also AdGuard for Windows 6.2 works fine with TCP Fast Open enabled.

Thus, this thread isn't relevant or (thankfully) needed anymore, so I'm going to close and unlock it now. :)
 
Status
Not open for further replies.
Top