Pale Moon legacy XPI support?

Boo Berry

Moderator + Beta Tester
Moderator
Is this posted in the wrong section? Adguard for Windows (which is the paid application) works perfectly with Pale Moon and will continue to do so (it's not a browser extension - it's a standalone application).

The Firefox-based legacy .xpi Adguard Adblocker browser extension (which is free and doesn't cost anything) might become a different story later in the year once it transitions to WebExtensions-only, something Pale Moon won't support. Not sure if the Adguard legacy extension for Pale Moon will continue to be developed because of that (don't honestly see the point to, since Firefox is moving on and the Pale Moon userbase is pretty small to warrant a legacy fork of the source code, IMO). @avatar or @vasily_bagirov can probably answer this one better.

If you're trying to use the legacy .xpi extension in Pale Moon with Adguard for Windows in integration mode, I highly suggest not doing so and just use the Adguard Assistant. IMO, there's no reason to use Adguard for Windows with the legacy .xpi Adguard Adblocker browser extension in Pale Moon at the same time.

If there's any confusion here, the legacy .xpi browser extension is free and not Adguard for Windows and may or may not work with Pale Moon in the future. Adguard for Windows is the paid application that does work without issue with Pale Moon (you *may* need to manually import the Adguard CA certificate into Pale Moon).
 

twistedvincent

New Member
No I posted here because I saw no progress in the last thread I posted in 2 years ago. I get a error something to the effect of no jetpack support.

Honestly I've used Pale Moon for so long that a really have no idea how to navigate thru the latest firefox and chrome...sad but true.
 

Boo Berry

Moderator + Beta Tester
Moderator
If you go through the browser extension release notes, you might find an older, working legacy .xpi browser extension: https://github.com/AdguardTeam/AdguardBrowserExtension/releases

I think 2.4.13 *might* still work: https://github.com/AdguardTeam/AdguardBrowserExtension/releases/tag/v2.4.13

EDIT: Ahh, I see, SDK extension support isn't there in Pale Moon 27. Yeah, it won't work anymore. Adblock Latitude and uBlock Origin seems to be the only working adblocking browser extensions for Pale Moon 27. Adguard for Windows works perfectly though, I just tested it.
 
Top