PIA Proxy & Local Proxy

naso

New Member
Hi! I'm trying out this app and I'm in the trial phase. I have an S8+ non-rooted, and I use PIA VPN.

Upon first loading the app, "Protection is disabled", I added a VPN proxy under "settings > network > proxy" and it is enabled and connects when tested. Unfortunately trying to enable protection doesn't work even after doing this. I try changing the filtering method to local HTTP proxy and it works ( still leaving the proxy enabled ) and my andriod vpn is still connected at this point as well. I try to enable protection again and it works, but in the notification bar AdGuard shows this : https://i.imgur.com/onD0vsi.png I'm wondering if it's working or have I messed something up?
 
Last edited:

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@naso

Hello there,

Your setup is a little bit incorrect. First of all, Android OS allow you to enable only one VPN service at a time - that means you should disable PIA, configure it as a proxy in AdGuard - Settings - Network - Proxy, then just activate the protection. You don't need to change the filtering method by switching it on local HTTP proxy (should be VPN).
 

naso

New Member
Hi,

I tried disabling my PIA VPN and then enabling AdGuard with the filtering back to normal, but it doesn't work. It displays this message, "AdGuard cannot create a VPN connection. It is possible that VPN is not supported by your firmware."
 

naso

New Member
Hey,

Yes I am running that version, I tried one more thing fully uninstalling PIA VPN app and then trying to enable the protection on adguard. This way worked, it was able to add the adguard VPN to the system.

PS: just wondering if adguard VPN encrypted and if they keep logs?
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@naso

You can delete the VPN (PIA) in System settings - Network - VPN and use PIA as a proxy in AdGuard (not in a local HTTP proxy mode)
 
Top