Problem with my ISP

Not open for further replies.
Hello all, I am from India and I have been using adguard dns service. I really appreciate your service and I am happy with it. Recently I changed my ISP JIO - which is a 4G VOLTE network. They provide a router called JioFi(, which provides fast Internet in our area. Also, if we install their application, we can make voice calls using the device.
The problem I am facing is that the management portal and the voice calling app is heavily dependent on the dns entry "jiofi.local.html" (resolves to If I change the default DNS to adGuard (or any other dns servers), both of them stops working.
Is it possible to add the entry to the adGuard dns resolvers, without which I cannot use adGuard.
Hi Alex, thanks for the reply. I understand that there may be issues if I change my DNS settings.
But the issue will be resolved if the dns server replies with, whenever I make a request with "jiofi.local.html". I can confirm that this will solve the issue, since I have setup a dns server in my GCP account and if that hostname resolves to, the issue is not there.

My question was "Is it possible to add the entry(jiofi.local.html -> to Adguard Server".


Filters Developer
Staff member
Our DNS redirects domains to or when they are must be blocked
Our DNS redirects domains to or when they are must be blocked
Hmm. Understood. But in this case it is very different.
Please check the possibility of adding this entry. Jio is a network with more than 160 million users, and this will surely help a lot of us. Otherwise we will have to live with full screen ads all over the web:(.
jiofi.local.html - is just a page, not domain.
No alex, that is the domain. Here is the DNS reply

host -a jiofi.local.html
Trying "jiofi.local.html"
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19551
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;jiofi.local.html. IN ANY

jiofi.local.html. 0 IN A
Not open for further replies.