Problems with installation v1.1.0

Discussion in 'AdGuard for Safari' started by Tomovich, Dec 9, 2018.

  1. Tomovich

    Tomovich New Member

    Joined:
    Dec 9, 2018
    Messages:
    7
    Hello

    I installed the new extension v1.1.0 from the Mac App Store but after installation the preferences window is blank. When I click on general, filters, whitelist... nothing happens. Everything below is blank.
    I use little snitch but I set up rules that allows all incoming and outgoing traffic for Adguard. What must I do?

    Thanks

    Edit: I’m on Mojave 10.14.2 with Safari 12
    Edit2: picture added [​IMG]
     
    Last edited: Dec 10, 2018
  2. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    989
    @Tomovich

    Hello!

    Did you try to delete and install AdGuard for Safari?
     
  3. Tomovich

    Tomovich New Member

    Joined:
    Dec 9, 2018
    Messages:
    7
    No I haven’t yet. How do I do that? From within the Safari preferences? Uninstall both extensions or...?
     
  4. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    989
    @Tomovich

    Correct. Safari - Preferences - Extensions - AdGuard - Delete.
     
  5. Tomovich

    Tomovich New Member

    Joined:
    Dec 9, 2018
    Messages:
    7
    When I click on “delete installation” for both extensions, I get the message that it is part of the application “Adguard for Safari” and that I need to go into the Finder to delete the app, that’s correct? Do I need to delete preference files too?
     
  6. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    989
    @Tomavich

    Correct, it will ask you to open Finder - Applications - AdGuard for Safari - Delete.
     
  7. Tomovich

    Tomovich New Member

    Joined:
    Dec 9, 2018
    Messages:
    7
    Deleting everything and reinstalling from the App Store gives the same, nothing has changed.
     
  8. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    989
    @Tomovich

    Any anti-viruses and extensions (Safari) are installed?
     
  9. Tomovich

    Tomovich New Member

    Joined:
    Dec 9, 2018
    Messages:
    7
    No antivirus. 1Password extension and Little Snitch app installed.
     
  10. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    989
    @Tomovich

    Can you disable Little Snitch restart Safari and try again?
     
  11. Tomovich

    Tomovich New Member

    Joined:
    Dec 9, 2018
    Messages:
    7
    I uninstalled Little Snitch, restarted and tried again but still the same.

    EDIT: I deleted the Adguard app again and reinstalled it, still the same. However, I got a message that a filter was updated. So I guess the app is working but I can't see anything in the preferences window. And I can't edit anything.
     
    Last edited: Dec 13, 2018
  12. jagita

    jagita New Member

    Joined:
    Dec 22, 2018
    Messages:
    5
    I installed the new extension v1.1.0 from the Mac App Store but after installation the preferences window is blank. When I click on general, filters, whitelist... nothing happens. Everything below is blank.
     
  13. TheHasagi

    TheHasagi Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    989
    Can you provide the steps to reproduce and what other extensions are installed?

    Please, provide a screenshot.
     
  14. Tomovich

    Tomovich New Member

    Joined:
    Dec 9, 2018
    Messages:
    7
    FYI: after all the steps I took above, nothing gave a solution. So I uninstalled it again and went with Wipr which is working fine.