Problems with weather.com on Fx again.

streetwolf

Beta Tester
In a nutshell weather.com under Fx does not display current information. This is based on displayed times and forecasts on weather.com. The only way I can get things to be current is to disable AG while Fx isn't running, go into Fx and enable AG again. This will only update weather.com to what's current. From then on the time and forecasts are usually never up to date anymore unless I disable/enable AG again. As a point of reference IE11 does not exhibit this behavior, it's always up to date.

I've tried everything I could think of to try and fix this issue in Fx. Safe mode, new profile, new cache, etc. etc. does not fix the problem. Seems like AG and weather.com on Fx don't get along. Does AG cache web pages and is using an old cached page?

If you want to use TeamViewer to see what's happening let me know.
 
Last edited by a moderator:

deleted

Beta Tester
Hello streetwolf
can you give some screenshot of how its not working and how its supposed to be....
I will also check on my system and give you feedback.
:)
 

streetwolf

Beta Tester
When you go to weather.com click on your location. It will take you to another screen which shows the time the page was updated as well as the forecast. Best to open up another browser such as IE11 to see if there are any differences. My updated time says 11:45 am which his wrong. Th forecasts are also from some other time.

Also when I click on the next few hours it shows a time of 10:26 am and the forecasts again are based on that time.

It is possible that everything will look OK at first. But give it an hour or so and see if everything updates to what's current.

Keep in mind I am on Nightly Fx41 64 bit. Your Sig indicates Fx38 32 bit. If you don't have the problem it might be because of out different versions of Fx.
 
Last edited by a moderator:

streetwolf

Beta Tester
My current time is 2:04 PM. This screenshot was correct about half and hour ago. Now suddenly the time is wrong.

Capture.JPG
 

streetwolf

Beta Tester
Haven't been to weather.com in hours. Just went there and it still says 11:45 am. Even reloading the page from the site doesn't change anything. Yet IE11 says it's 6:45 PM which is correct.

Just closed AGW and the time updated to 6:45 PM. Sometime soon I will get another time in the past.

Things still aren't right even though the time is correct. If I click on the Next Few Hours the time on top is correct but the forecast starts at 11:00AM for tomorrow. IE11 starts at 7:15 PM today which is correct. Just clicked on Next Few Hours in Fx and it now matches what IE11 has. Things won't be the same for long.

Really something weird going on here.
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
It's giving me the wrong time regardless of browser and regardless of Adguard's filtering enabled or disabled.
 

streetwolf

Beta Tester
It's giving me the wrong time regardless of browser and regardless of Adguard's filtering enabled or disabled.
It's not just the time but the times and dates on forecasts. IE11 works flawlessly for me. Is IE11 also giving you incorrect info?

Try closing AGW instead of just disabling it. I found that disabling AGW didn't always correct the problem. I also switched to TDI but that didn't help.
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
Where's the date listed at?

EDIT: Is the date listed under the Map? For me it's correct with it displaying Jun 21, 2015, 6:40pm CDT.

---------- Post added at 06:45 PM ---------- Previous post was at 06:42 PM ----------

And to think of it, the incorrect time may not actually be incorrect time - it could be the last time the current conditions was updated.
 

streetwolf

Beta Tester
It is the last time the current conditions were updated. If you are going to weather.com click on the location to get you to the screen with the problems. The updated time is on the upper left right below your location. I have this page bookmarked so I get to this page directly.

Look at the capture.jpg link I gave in a post above. That should be the screen you are on.

Here's the URL in my bookmark .... http://www.weather.com/weather/today/l/07746 Perhaps playing around with this page will show you the problem.
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
I'm looking at the current conditions for my area and looking in the same area you have highlighted above, and yes, the time is off but I believe that's the time the current conditions for our areas was last updated, not the current time. Same for the Maps area below too.

Regardless of browser and regardless if Adguard is enabled, disabled or completely closed it remains the same for me.
 
Last edited by a moderator:

streetwolf

Beta Tester
But I get updated times that are hours ago and forecasts that are also old. When I close AG all seems OK but all those ads really slows down the site. As I said above Avatar might have to use TeamViewer to see what I see.

Right now the updated time says 7:05 PM. IE11 says 7:45 PM which seems correct to me.

AFAYK does AG cache any sites?
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
Odd. Not seeing this issue here - my current conditions for my area was just updated. My best guess it's a filters issue. But then again I'm just using the English and User filters.
 

streetwolf

Beta Tester
The bottom line is this. AG not active at all (closed it) weather.com displays update times/forecasts up to date. AG running and enabled weather.com shows different updated times and forecasts. As I said earlier IE11 works perfectly with AG.

Wonder if I uninstall AG and reinstall that might fix things. Anyone have the link to the latest beta?
 

deleted

Beta Tester
The things is my FF(which is monitored by AG) and my chrome(which ain't monitored) are showing the same info. :/
So I'm not really sure what the issue is.
And I don't have IE to test.

---------- Post added at 07:21 AM ---------- Previous post was at 07:19 AM ----------

p.s. you can always get the latest beta using this link:-

Code:
http://download.adguard.com/beta/setup.exe
 

avatar

Administrator
Staff member
Administrator
Hi @streetwolf!

Could you please check this rule:
Code:
weather.com#%#localStorage.removeItem('dsxcache');
That is not final solution, just trying to narrow it down.
 
Top