Problems with weather.com on Fx again.

streetwolf

Beta Tester
Still getting the next few hours forecasts from yesterday instead of today. Let me try the stable version of Fx.

---------- Post added at 08:08 AM ---------- Previous post was at 07:48 AM ----------

I am now testing on portable version Fx 38.0.5 32 bit. I'll get back to you in a little while my results.

---------- Post added at 08:38 AM ---------- Previous post was at 08:08 AM ----------

Basically the same results on Fx 38.0.5.

---------- Post added at 08:43 AM ---------- Previous post was at 08:38 AM ----------

When I set the cache to zero everything appears OK so far in the portable and my Nightly version. Could AG be interacting with the cache in some manner when there is a cache? So there appears to be two ways to get the correct info:

1. Set cache to zero with AG running
2. Set cache to a non-zero value and close AG

---------- Post added at 09:15 AM ---------- Previous post was at 08:43 AM ----------

Running with zero cache is keeping things up to date. I compare them to IE11 and they are always exactly the same.

---------- Post added at 11:05 AM ---------- Previous post was at 09:15 AM ----------

Do you need anything from me to try and resolve this problem?
 

streetwolf

Beta Tester
I reported somewhere above. It didn't help. So far running with no cache keeps weather.com up to date. I can live without a cache due to the Internet speed I have, but somethings would be better if they were cached.
I was getting crazy stuff when using a cache. This morning I had forecasts from yesterday. There must be some tie in between the cache and AG (just a guess).

---------- Post added at 11:30 AM ---------- Previous post was at 11:27 AM ----------

One more thing. When I was using a cache I closed AG and stopped the AG service. I then used the Fx AG extension. It did the same thing. I'm now also wondering if other sites are not up to date when using a cache and AG.

---------- Post added at 12:32 PM ---------- Previous post was at 11:30 AM ----------

After running for an hour ans a half with no cache and weather.com working fine I now turned on the cache. I am starting to see the same problems; past update times and past forecasts. Even current temps for some areas near me are different from what IE11 shows. The temps are lower which indicates to me they were from a previous time.

---------- Post added at 01:50 PM ---------- Previous post was at 12:32 PM ----------

I think this problem appears on other sites as well. Over at cnn.com I always wondered why the stock market quotes had updated times that were hours in the past. Now that I have no cache I see that the updated time is about 15 minutes or so ago.
 

Boo Berry

Moderator + Beta Tester
Moderator
Just a thought, does this happen when Browsing Security is disabled in Adguard? Might try disabling all extensions too.
 

streetwolf

Beta Tester
I tried everything you can imagine as in all my posts. There are only two ways I've found to keep weather.com updated properly.

1. Completely stop AG. This includes the Service too although I don't think I need to do this. Right now I am running without AG. I installed the Fx add-on uBlock just so I wouldn't have to put up with all the ads. weather.com is updating fine although I notice that one of the update times is 1 minute different than what IE11 shows.

2. Run with no cache in Fx. AG can be running with no cache and weather.com updates fine. It's interesting there is no one minute difference in one of the update times like in #1 above.

---------- Post added at 07:04 PM ---------- Previous post was at 07:00 PM ----------

Looks like I still getting some update problems. Let me disable uBlock and see what happens. This is really, really weird.
 

streetwolf

Beta Tester
Any work being done one this? I can say for a fact that without AG running I get more up to date stuff on the site. I also believe that there is also a problem with Fx because some items in a forecast don't always show up. Once again IE11 is perfectly fine with or without AG running.
 

streetwolf

Beta Tester
Also I didn't mention that forcing the page to load from the site (Ctrl-F5) and not the cache doesn't fix the problem.
 

streetwolf

Beta Tester
Cleared everything as Andrey pointed out. Have to wait for the top of the hour to see if weather.com will update. This is about 5 minutes from now.

---------- Post added at 03:05 PM ---------- Previous post was at 02:56 PM ----------

Didn't work :(
 

streetwolf

Beta Tester
Andrey..

I cleared my cache and just went to the one site weather.com. I then exited Fx and looked at my cache with Nirsoft's Mozilla Cache Viewer. I find a few css files like these in there. Can these be the cause of my problem?

Filename:v635709252958435278.css

URL: http://injections.adguard.com/adguard-ajax-api/injections/adg_css_4.css?rand=635709252958435278

Cache Control: max-age=2592000

I also find if I clear my cache weather.com is fine until it's updated the next time or the time after that.

---------- Post added at 03:27 PM ---------- Previous post was at 02:33 PM ----------

I have no idea what this means but if I delete just one file out of the cache, weather.com will show current until I exit Fx and restart it.
 
Last edited by a moderator:

streetwolf

Beta Tester
Is there a way to prevent the domain weather.com from writing to the cache or at least preventing it from using the cache. If there is a way this might be a workaround for my problem. Perhaps some js code in a userscript?
 

streetwolf

Beta Tester
Found another way to get things working as they should. I right click on my weather.com bookmark and select 'Open in a new private window'. This results in weather.com being up to date. Probably due to that fact that in Private Mode there is no cache among other things.
 

streetwolf

Beta Tester
Already tried that and it didn't work. Andrey was on my system and saw what was happening and I think he agreed that AG was doing something. At this point I don't know if he is pursuing the problem as it appears I am the only one having the problem.

---------- Post added at 06:38 PM ---------- Previous post was at 06:35 PM ----------

It's strange that at this moment weather.com is fine. But it won't be after one or two updates on the site.

---------- Post added at 06:43 PM ---------- Previous post was at 06:38 PM ----------

Just found something interesting. I was going to weather.com using the Awesome Bar which contained an entry for weather.com. Tried it a few times and the site was up to date. I then bookmarked the site as I usually do and the site was 15 minutes behind when I used it. I deleted the bookmark, restarted Fx, and used the Awesome Bar again and it was the correct time. Hmmmm....

---------- Post added at 06:45 PM ---------- Previous post was at 06:43 PM ----------

Forget what I last said. Now the time is 45 minutes behind.

---------- Post added at 06:51 PM ---------- Previous post was at 06:45 PM ----------

I'll just run without a cache. I think I'm having similar problems on CNN weather. I don't see any difference in page updating with or without a cache. Maybe it's my high Internet speeds.

---------- Post added at 07:07 PM ---------- Previous post was at 06:51 PM ----------

Yeah it looks like the weather at cnn.com is affected too. All of this happened within maybe a month. Possibly with a beta. Do you think it's worth the effort to see if there is a regression by trying earlier versions to see if they work and then try the next versions and so on to see what version caused the problem.
 
Top