[Resolved] AdGuard blocking spell check for google search

alex14469

New Member
Hello,

I noticed that while Adguard is enabled, spell check does not work when searching on google.com. Spelling suggestions are not displayed in search results.

Please let me know if there is a way to add an exception without allowing ads in search results.


Thank you.
 

alex14469

New Member
Browser does not matter, I tested with IE, Edge and Chrome (win10) and had the same issue on win8.1

I tried to disable a couple of filters, russian filter blocks spell check. Unchecking the russian filter does the trick but I do need it.
 

Alex302

Filters Developer
Staff member
Administrator
Browser does not matter, I tested with IE, Edge and Chrome (win10) and had the same issue on win8.1

I tried to disable a couple of filters, russian filter blocks spell check. Unchecking the russian filter does the trick but I do need it.
Hi
Can you describe this step-by-step with screenshot? I can't reproduce it(or don't understand) - when entered words with errors, google suggests the correct variant.
 

alex14469

New Member
When I search something on google.com, google suggests correct spelling when necessary (screenshot link below). The problem is that if I enable the Russian filter in AdGuard spelling suggestions no longer show up.

Russian filter OFF:
http://i.imgur.com/HJkTulE.png

Russian filter ON:
http://i.imgur.com/34lesP4.png


Please let me know if there is a way to use the Russian ad filter without blocking spell check on google.com
 

Alex302

Filters Developer
Staff member
Administrator
When I search something on google.com, google suggests correct spelling when necessary (screenshot link below). The problem is that if I enable the Russian filter in AdGuard spelling suggestions no longer show up.

Russian filter OFF:
http://i.imgur.com/HJkTulE.png

Russian filter ON:
http://i.imgur.com/34lesP4.png


Please let me know if there is a way to use the Russian ad filter without blocking spell check on google.com
It is ok om my side:
http://s1.micp.ru/707I4.jpg
You didn't answer - what filters turned on.
 

avatar

Administrator
Staff member
Administrator
Alex, I am pretty sure the problem is with your browser language.
Maybe Google does no spell check if you use non-english locale.
 

Alex302

Filters Developer
Staff member
Administrator
When I search something on google.com, google suggests correct spelling when necessary (screenshot link below). The problem is that if I enable the Russian filter in AdGuard spelling suggestions no longer show up.

Russian filter OFF:
http://i.imgur.com/HJkTulE.png

Russian filter ON:
http://i.imgur.com/34lesP4.png


Please let me know if there is a way to use the Russian ad filter without blocking spell check on google.com
Please check this rule in User filter:
Code:
google.com,google.ru#@##taw
or wait for updates(removed this rule).
 
Last edited by a moderator:

alex14469

New Member
Thank you for the help, it worked. I added the the string you provided (google.com,google.ru#@##taw) with @@|| to my user filter and now everything works perfectly with russian filter enabled.
 
Top