_Marek_

New Member
Hello
I wanted to report that aternos anti adblock detects adguard etc
Link:
8vhNXJGiMp.png


  • AdGuard for Windows 7.6 nightly 24
  • DNS: AdGuard DNS (DNS over QUIC) DNS filters: 0
  • Chrome ver 89.0.4389.90 (64-bit)

    A list of enabled filters in AdGuard app:
Ad Blocking:
  • AdGuard Base filter
  • AdGuard Mobile Ads filter
  • Easy List
  • Peter Lowe`s Blocklist

Privacy:
  • AdGuard Tracking Protection
  • EasyPrivacy
  • Fanboy`s Enhanced Tracking List

Social Widgets:
  • AdGuard Social Media filter

Annoyances:
  • AdGuard Annoyances filter
  • Fanboy`s Annoyances
  • Web Annoyances Ultralist
  • Adblock Warning Removal List

Security:
  • Online Malicious URL Blocklist
  • Spam404
  • NoCoin Filter List

Other:
  • AdGuard Russian filter
  • AdGuard Chinese filter
  • AdGuard Japanese filter
  • EasyList CHina
  • EasyList Germany
  • Official Polish filters for AdBlock,uBlock Origin & AdGuard
  • Polish GDPR-Cookies Filters
  • Polish Social Filters
  • Polish Annoyances Filters
  • Polish Anti Adblock Filters
  • EasyList Polish
  • Polish Anti-Annoying Special Supplement


User List:
  • Adblock Warning Removal List
  • 1HostsPro
  • Anti-Paywall filters
  • Paywall Remover
  • Windows Filter Types Firewall HTTP-Only
I also tested aternos website with only AdGuard Filters:
  • AdGuard Base Filter
  • AdGuard TrackingProtection
  • AdGuard Annoyances filter
  • AdGuard Experimental filter
How to reproduce the test:
  1. Create an account on https://aternos.org/
  2. Log In
  3. In user panel click "Create a server" then again click "Create"now anti adblock error/msg should popup
Video:
https://streamable.com/9kemvk
 
Last edited:

Adam

Filters Developer
Staff member
Moderator
The problem with this website is that when we fix it, they every time update their anti-adblock script after a while.
Please try to add these rules to user filter:
Code:
aternos.org#@%#!function(){window.pbjs={cmd:{push:function(){}},adUnits:function(){}};window.snhb={globalSettings:{},startAuction:function(){}};window.pbjsChunk=()=>{}}();
aternos.org#%#!function(){window.googletag={destroySlots:()=>{return true;},display:()=>{}};window.__cmp=()=>{};window.pbjs={cmd:{push:function(){}},adUnits:function(){}};window.snhb={globalSettings:{a:{}},startAuction:function(){}};window.pbjsChunk=()=>{};}();
aternos.org#%#(function(){var e=new MutationObserver(function(){for(var c=document.getElementsByTagName("script"),b=0;b<c.length;b++){var a=/atob\("([\s\S]*?)"\)/;if(c[b].text.match(a)){var d;a=c[b].text.match(a)[1];a=a.replace(/[^A-Za-z0-9\+\/=]/g,"");if(a=null===(d=atob(a).match(/&& window\['([\s\S]*?)'\] instanceof Array/))||void 0===d?void 0:d[1]){e.disconnect();Object.defineProperty(window,a,{value:[]});break}}}});e.observe(document,{childList:!0,subtree:!0});setTimeout(function(){e.disconnect()},5E3)})();
aternos.org$$script[tag-content="Function(atob(""Y29uc"][min-length="4000"][max-length="7000"]
 

_Marek_

New Member
The problem with this website is that when we fix it, they every time update their anti-adblock script after a while.
Please try to add these rules to user filter:
Code:
aternos.org#@%#!function(){window.pbjs={cmd:{push:function(){}},adUnits:function(){}};window.snhb={globalSettings:{},startAuction:function(){}};window.pbjsChunk=()=>{}}();
aternos.org#%#!function(){window.googletag={destroySlots:()=>{return true;},display:()=>{}};window.__cmp=()=>{};window.pbjs={cmd:{push:function(){}},adUnits:function(){}};window.snhb={globalSettings:{a:{}},startAuction:function(){}};window.pbjsChunk=()=>{};}();
aternos.org#%#(function(){var e=new MutationObserver(function(){for(var c=document.getElementsByTagName("script"),b=0;b<c.length;b++){var a=/atob\("([\s\S]*?)"\)/;if(c[b].text.match(a)){var d;a=c[b].text.match(a)[1];a=a.replace(/[^A-Za-z0-9\+\/=]/g,"");if(a=null===(d=atob(a).match(/&& window\['([\s\S]*?)'\] instanceof Array/))||void 0===d?void 0:d[1]){e.disconnect();Object.defineProperty(window,a,{value:[]});break}}}});e.observe(document,{childList:!0,subtree:!0});setTimeout(function(){e.disconnect()},5E3)})();
aternos.org$$script[tag-content="Function(atob(""Y29uc"][min-length="4000"][max-length="7000"]
I added all 4 to user filters and now everything works fine :) 0 problems/anti adblock alerts
thx you
 
Top