[Resolved] Facebook slow with English filter

The Seeker

New Member
I am experiencing the same issue as outlined here on reddit - namely Facebook is extremely sluggish with the English filter enabled. Disabling it in favour of the EasyList filter immediately rectifies the issue after a page refresh.

I have not used the report tool as it requires screenshots, which this issue doesn't require.

Windows 10 Pro 64-bit
AdGuard for Windows (stable version)
Chrome 64-bit (stable version)
 

Blaz

Moderator & Translator
Staff member
Moderator
Not reproduced. Easylist does not contain rules for timeline ads and I guess those ext-css rules are causing that slugginess on older devices.

You can try to disable those ext-css rules containing Facebook.com and the following variants:

:has
[-ext-has
 

The Seeker

New Member
Just a guess when seeing older devices in generic.
My laptop is running a Core i5, has an SSD, and 12GB of RAM. Not at the cutting edge, but by no means a slouch.

The sluggishness I'm experiencing only started occurring last night, and is something I've not seen on Facebook after using AG for several weeks now. The fact that the slowness goes immediately when switching filter lists makes me think there's something on the English filter that is causing this.

You can try to disable those ext-css rules containing Facebook.com and the following variants:

:has
[-ext-has
Are these rules recent additions to the English filter?
 

Blaz

Moderator & Translator
Staff member
Moderator
Yep, that one doesn't sound like an oldtimer.

I remember the night from 27th to 28th an existing ext-css rule got changed to fix an ad.

https://github.com/AdguardTeam/AdguardFilters/commit/db8cc7d426cb3df6747fda87657025a7265cd799

You may try to only disable this new rule in English filter and check again. If the issue is gone, will have to check if we can speed it the rule up a bit.

EDIT: You can also add this rule to disable that rule:
facebook.com##div[id^="substream_"] div[id^="hyperfeed_story_id_"]:has(div[id^=feed_subtitle] > span > a[href="#"] > div [class]:not(.timestampContent))


Suggestion rule to replace it in case above works for you:
facebook.com##div[id^="substream_"] div[id^="hyperfeed_story_id_"][-ext-has='div[id^="feed_subtitle"] > span > a[href="#"] > div[class] > div[class]:not(.timestampContent)']
or
facebook.com##div[id^="substream_"] div[id^="hyperfeed_story_id_"]:has(div[id^="feed_subtitle_"] a[href="#"] div[class] > div[class])
 
Last edited:

The Seeker

New Member
You may try to only disable this new rule in English filter and check again. If the issue is gone, will have to check if we can speed it the rule up a bit.
Code:
facebook.com##div[id^="substream_"] div[id^="hyperfeed_story_id_"]:has(div[id^=feed_subtitle] > span > a[href="#"] > div [class]:not(.timestampContent))
This rule is the culprit for sure. Disabling the rule then a shift + refresh of the page has an immediate effect, i.e. sluggishness disappears. Enabling the rule then a shift + refresh reintroduces the issue.

Thanks for your help :)
 

Blaz

Moderator & Translator
Staff member
Moderator
OK, could you please try one of the following rules with above rule still disabled:

facebook.com##div[id^="substream_"] div[id^="hyperfeed_story_id_"][-ext-has='div[id^="feed_subtitle"] > span > a[href="#"] > div[class] > div[class]:not(.timestampContent)']
or
facebook.com##div[id^="substream_"] div[id^="hyperfeed_story_id_"]:has(div[id^="feed_subtitle_"] a[href="#"] div[class] > div[class])

Both hide the ad, just a different approach.
 
Top