[Resolved] File-upload.com

Mike Yagi

New Member
URL: https://www.file-upload.com/9iwlweei1emc

A full screen alert is shown asking to enable JavaScript - which is already enabled; This alert doesn't go away until AdGuard is disabled or the site is whitelisted, an anti-adblock measure.

Please see the attached screenshots

2018-10-09 03.10.36.png 2018-10-09 03.11.19.png

I'm using AdGuard Content Blocker, Samsung Internet 7.4

My filters: English, German, Russian, Annoyances, Spy, Social, Liste-AR, Mobile
 

Blaz

Moderator & Translator
Staff member
Moderator
Can you please check these rules in user filter, thank you (one by one):
Code:
@@||file-upload.com^$generichide
@@||file-upload.com^$elemhide,important
 

Mike Yagi

New Member
I tried each rule one by one then both rules together, but no effect.

PS. After double checking, even whitlisting the whole 'file-upload.com' domain doesn't help, the only way is to disable AdGuard completely, seems that it's loading the detection script from a 3rd-party domain or using some other technique.

EDIT: Sorry, my last paragraph is wrong, actually it works if the whole domain is whitelisted with this rule:

Code:
@@||file-upload.com$document
 
Last edited:

Blaz

Moderator & Translator
Staff member
Moderator
Sadly I can't reproduce. Please check @Adam.

You may try this rule:
Code:
@@||file-upload.com^$genericblock
 

Blaz

Moderator & Translator
Staff member
Moderator
Could you please check only with English filter and ensure filters are up2date (disable the mentioned rule first). Just tried on a 2nd device on Samsung Internet with Content blocker and not reproduced with up2date filters.
 

Mike Yagi

New Member
When only the 'English filter' is enabled the issue cannot be reproduced.

I then started enabling my other filters one by one, the one that triggers the issue is the 'Social media filter'.

---

All filters are up to date.
The custom rule is disabled.
 

Blaz

Moderator & Translator
Staff member
Moderator
Please check either of these rules ( I guess first one will work):

Code:
@@||apis.google.com/js/platform.js$domain=file-upload.com
@@||web.facebook.com/*/plugins/like.php$domain=file-upload.com
More blocked requests by Social filter is not shown when I check the site.
 

Mike Yagi

New Member
1. Enabled all my filters.
2. Disabled the rule you provided earlier.

3. Tried the first rule
Code:
@@||apis.google.com/js/platform.js$domain=file-upload.com
-- It works as well, fixed the issue.

4. Disabled it.

5. Tried the second rule:
Code:
@@||web.facebook.com/*/plugins/like.php$domain=file-upload.com
-- It has no effect whatsoever.
 

Mike Yagi

New Member
Using any of these two rules worked and fixed the issue:
Code:
@@||file-upload.com^$genericblock
Code:
@@||apis.google.com/js/platform.js$domain=file-upload.com
-- which one I should be using?
 
Top