[Resolved] http://livetv.sx

ag_bug_finder

Beta Tester
It doesn't work on my end.
I hate not catching these things while they're actually working and easy to fix so that they can be fixed once and for all.
Its so hard to find the same issue on demand.

I found a different issue. Lets hope we can fix this one, while I still search for the other ones again.
http://cdn.livetvcdn.net/webplayer.php?t=ifr&c=401626&lang=en&eid=402249&lid=401626&ci=785&si=72
http://s13i.imgup.net/ADse235.png

---------- Post added at 02:48 AM ---------- Previous post was at 02:39 AM ----------

http://cdn.livetvcdn.net/webplayer2.php?t=ifr&c=401427&lang=en&eid=402080&lid=401427&ci=1002&si=41
Click on 2. Ads will be shown. Please fix. http://x20i.imgup.net/23991.png
Click on 3. Ads will be shown. Please fix.
Click on 5. Ads will be shown. Please fix. http://n24i.imgup.net/528be.png
 
Last edited by a moderator:

Blaz

Moderator & Translator
Staff member
Moderator
Link http://cdn.livetvcdn.net/export/webplayer.iframe.php?t=ifr&c=405421&lang=de&eid=403064&lid=405421&ci=72&si=4 is getting its content from http://www.mystreans.com/live/live19.html

Sadly when I put the following code into an AG_onLoad (even with timeout), it is not executed, same for the normal way to block it :(

Code:
document.getElementsByClassName('bannerfloat')[0].style.display = "none";
document.getElementById('closeAdButton2').style.display = "none";
document.getElementById('bannerfloat').style.display = "none";
To remove that logo you mentioned:
Code:
||userlogos.org/files/logos/igor23/livetv_black.png
Your link resolves to http://streamlivebox.com/live/attheraces.html (normal ways didn't hide it):
Code:
||i.imgur.com/AW6QOE1.png
 
Last edited by a moderator:

ag_bug_finder

Beta Tester
Will these rules be added to English?
||userlogos.org/files/logos/igor23/livetv_black.png
||i.imgur.com/AW6QOE1.png


-------------------------------------------------------------------------

These rules don't work which you know:
document.getElementsByClassName('bannerfloat')[0].style.display = "none";
document.getElementById('closeAdButton2').style.display = "none";
document.getElementById('bannerfloat').style.display = "none";


This must be an Adguard bug.
Could someone please fix the issue?
 
Last edited by a moderator:

Blaz

Moderator & Translator
Staff member
Moderator
Those “rules“ only work when entered into Chrome console. They were meant as an info.
 

Alex302

Filters Developer
Staff member
Administrator
For Extension - added to English filter:
Code:
mystreans.com###bannerfloat
mystreans.com###close1
mystreans.com###closeAdButton2
For desktop version - added to Experimental filter:
Code:
||mystreans.com/live/live*.html$replace=/<\/title>/<\/title><style>#bannerfloat\,#close1\,#closeAdButton2 { display: none; }<\/style>\,/i
 

ag_bug_finder

Beta Tester
For Extension - added to English filter:
Code:
mystreans.com###bannerfloat
mystreans.com###close1
mystreans.com###closeAdButton2
For desktop version - added to Experimental filter:
Code:
||mystreans.com/live/live*.html$replace=/<\/title>/<\/title><style>#bannerfloat\,#close1\,#closeAdButton2 { display: none; }<\/style>\,/i
Do both the desktop and extension filters get loaded on the desktop?

======================

I tested with this rule on the desktop Adguard.
||mystreans.com/live/live*.html$replace=/<\/title>/<\/title><style>#bannerfloat\,#close1\,#closeAdButton2 { display: none; }<\/style>\,/i

All three issues remain here:
http://streamlivebox.com/live/attheraces.html
1. X to close ad on video.
2. X to close ad on video.
3. The top right "Live TV" logo is still on the top right of the video.

======================

Two issues remain here:
http://cdn.livetvcdn.net/export/webplayer.iframe.php?t=ifr&c=405421&lang=de&eid=403064&lid=405421&ci=72&si=4
1. X to close ad on video appears after about 1 minute of watching the video.
2. The top right "Live TV" logo is still on the top right of the video.
 

Blaz

Moderator & Translator
Staff member
Moderator
The problem with the last link which gets its content from http://www.mystreans.com/livetv/19.html is, Adguard is not injected into the site and therefore hide rules do not work. Very likely the site is kind of broken and therefore Adguard is not injecting itself.

Therefore current way to block those items are the following rules:
Code:
||mystreans.com/livetv/Livetv.gif
||mystreans.com/ch/closs.png
||mystreans.com/ch/adclose.png
 
Top