[Resolved] http://www.stream2watch.co

ag_bug_finder

Beta Tester
[Adguard for Windows 6.1.236.1160ß]

Comment: Click any black area that is just empty white/black space (not any links) and you'll see that pop-op windows are opened. This happens for about four or five clicks, before clicking on the empty white/black space does nothing. To reproduce again after first instance, you msut clear total cache, cookies, etc before trying again.
Website: http://www.stream2watch.co/live-now

NOTE: This may have something to do with this http://b21i.imgup.net/screenshota2e1.png
 
Last edited:

Blaz

Moderator & Translator
Staff member
Moderator
Code:
stream2watch.co##div[class]:not([class^="footer"]):not([class^="ea "]):not([class^="main"]):not([class^="_messages"]):not([class^="header_menu"]):not([class^="hpush"]):not([class$="head"]):not([class^="stream"]):not([class$="int"]):not([class^="popular"]):not([class^="fb-"]):not([class^="search"]):not([class^="results"]):not([class^="player"]):not([class^="notif"]):not([class^="chat"]):not([class^="code"])
stream2watch.co$$script[tag-content="eval(function(p,a,c,k,e,d)"]
stream2watch.co##div[class*="1468"]
stream2watch.co##body > div:last-child
All four rules should work, while the first one is a bit more dangerous and the 2nd one doesn't work in Extension.

For the ad:
Code:
stream2watch.co##.fpl
 
Last edited:

ag_bug_finder

Beta Tester
Code:
stream2watch.co##div[class]:not([class^="footer"]):not([class^="ea "]):not([class^="main"]):not([class^="_messages"]):not([class^="header_menu"]):not([class^="hpush"]):not([class$="head"]):not([class^="stream"]):not([class$="int"]):not([class^="popular"]):not([class^="fb-"]):not([class^="search"]):not([class^="results"]):not([class^="player"]):not([class^="notif"]):not([class^="chat"])
stream2watch.co$$script[tag-content="eval(function(p,a,c,k,e,d)"]
Both rules should work, while the first one is a bit more dangerous and the 2nd one doesn't work in Extension.
The first rule doesn't work, as when you click on one of the streams, the video doesn't appear on next screen.
The second rule works well though.
 

Blaz

Moderator & Translator
Staff member
Moderator
Meanwhile I updated the first rule a bit, please try the updated one.
But not seeing the ad you are talking about.

Also added a third option for the overlay.

The safest variant is #2 and for extension #3 (but when they update the code #3 shouldn't work anymore and #1 can hide useful stuff).
 
Last edited:

ag_bug_finder

Beta Tester
Meanwhile I updated the first rule a bit, please try the updated one.
But not seeing the ad you are talking about.

Also added a third option for the overlay.

The safest variant is #2 and for extension #3 (but when they update the code #3 shouldn't work anymore and #1 can hide useful stuff).
I tried the first rule again, and it STILL doesn't work...
Perhaps don't worry about this further, as option #2 works great. No other options needed really when someone works well.

As for the other ad -> http://f60i.imgup.net/screenshot2c71.png
When that progress bar (under the video area) gets filled up, this while fake video ad disappears and the real video player shows up and starts playing the video correctly.
 

Blaz

Moderator & Translator
Staff member
Moderator
Code:
stream2watch.co##.fpl
Strangely the first rule let's me play the video fine.
Stream #3 doesn't produce an ad here.
 

ag_bug_finder

Beta Tester
Code:
stream2watch.co##.fpl
Stream #3 doesn't produce an ad here.
Did you click on Stream 3 properly?
I ask, because you seem to have to click on Stream 3 twice or more times before it loads properly.
NOTE: Happens when you click twice or three times on either Stream 2, 3 or 4.
Tried multiple times, ad shows up each and every time.
 

Blaz

Moderator & Translator
Staff member
Moderator
I only see it when i disable Adguard:
Code:
stream2watch.co##div[class^="adk2_"]
 

ag_bug_finder

Beta Tester
The following rules have been tested and are working.
Code:
stream2watch.co$$script[tag-content="eval(function(p,a,c,k,e,d)"]
stream2watch.co##.fpl
stream2watch.co##div[class^="adk2_"]
stream2watch.co##.a-el
@Alex302, please add rule(s) to filters.
 

Alex302

Filters Developer
Staff member
Administrator
I see only white rectangle in the player:
Code:
streamgaroo.com###html3
Could you provide me remote access?
 

ag_bug_finder

Beta Tester
@ag_bug_finder please check again without the rules. I can't reproduce an issues.
You may as well just add the rules, because the issues will surface again and then need to be reported again, and by the time you see it again things may change.
Blaz and I both saw the issues and his rules worked well in my testing. You have to be quick on these streaming issues, and if you're not, then you keep missing out on easily seeing the issue and the fix.
 
Top