[Resolved] Missed ads on www.wp.pl

Adam

Filters Developer
Staff member
Moderator
@Alex302
Remind me on next week, please.
I have two more questions.

1. Which of these rules have a higher priority in Adguard?
This " ##.afs_ads " or this " #@#.afs_ads "?

2. Is it a special rule or a mistake?
Code:
||vesti.lv##.banner
||vesti.lv###subscribe-banner
These rules are from English filter.
 

Alex302

Filters Developer
Staff member
Administrator
@Alex302


I have two more questions.

1. Which of these rules have a higher priority in Adguard?
This " ##.afs_ads " or this " #@#.afs_ads "?

2. Is it a special rule or a mistake?
Code:
||vesti.lv##.banner
||vesti.lv###subscribe-banner
These rules are from English filter.
1. domain.com#@#.selector is exclusion for element hiding rules. Priority for exclusion is higest.
2. Yes, it is mistake. Fixed.
 

Adam

Filters Developer
Staff member
Moderator
Thank you for answer.
1. domain.com#@#.selector is exclusion for element hiding rules. Priority for exclusion is higest.
This exclusion works only for domain or can be set globally for all domains?
I ask, because I use Adguard for Windows with these filters - English filter, Experimental filter, Anti-Adblock Killer | Reek, Adblock polskie reguły, and in English filter is this rule " ##.afs_ads ", but in Anti-Adblock Killer list is this " #@#.afs_ads ".
Some websites detect "adblock" when class "afs_ads" is hidden/removed/blocked and therefore this is excluded in AAK list- https://github.com/reek/anti-adblock-killer/issues?q=label:"AdBlockBlocker+(afs_ads)"

For example here http://smiechawatv.pl/ and here http://www.filmyhd-online.com/ and here http://newhdmovie24.me/ "adblock" is detected because Adguard hides/removes "afs_ads".
Theoretically "adblock" should not be detected because in AAK list is this rule " #@#.afs_ads ", but despite this Adguard hides/removes "afs_ads" and "adblock" is detected.
So should I manually uncheck " ##.afs_ads " in filter editor in English filter or can you do something with it?
 

caleb59

Member
Worked like a charm but this is temporary solution...
@Alex302 please enable multiregex support in Adguard - this issue will come back from time to time without it!

Thank you!
 

Alex302

Filters Developer
Staff member
Administrator
Heh, please wait a bit... Not all users updated their extensions..
 

caleb59

Member
@Alex302 I don't understand - in that case we will wait forever...
If they are too lazy to update their extensions why other users (include me) must suffer a lack of multi regex function in Adguard?
Maybe this is not so simple - please explain "how it works" and when exactly you will be ready to enable this function again in Adguard...
We've been waiting for 6 weeks!
 
Last edited:

avatar

Administrator
Staff member
Administrator
That's not about users, it is about Apple review process. We have pushed new extension version update weeks ago, still waiting for it to pass the review process.
 
Top