[Resolved] outlook.live.com

freshhh

Active Member
outlook.live.com
(updated lately)

how to remove the empty ad containers on the right to gain space?
 

Boo Berry

Moderator + Beta Tester
Moderator
Make sure you're using these rules;

Code:
outlook.live.com#$#._n_i > div[style$=" height: auto; width: auto;"] { width: 100%!important; }
outlook.live.com###primaryContainer > ._n_p
outlook.live.com#$#._n_i> div[style*="width: auto; height: auto; right: 165px;"] { width: 100%!important; }
With these the right ad container is removed in all browsers, even Edge and IE.
 

Alex302

Filters Developer
Staff member
Administrator
Make sure you're using these rules;

Code:
outlook.live.com#$#._n_i > div[style$=" height: auto; width: auto;"] { width: 100%!important; }
outlook.live.com###primaryContainer > ._n_p
outlook.live.com#$#._n_i> div[style*="width: auto; height: auto; right: 165px;"] { width: 100%!important; }
With these the right ad container is removed in all browsers, even Edge and IE.
Where are these blocks? I don't see them
http://ipic.su/img/img7/fs/kiss_79kb.1460036272.png
Maybe URL is different?
 

Boo Berry

Moderator + Beta Tester
Moderator
They're there. Those are the rules you created a month or so ago when you remoted in and fixed it for Edge. ;)

IMO, those three rules could be added to the English filter since they work well without any negative effects.
 

freshhh

Active Member
Ok I found the problem. Conflict between user / default rules!
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
It's broken in Edge again on Outlook when using the latest Windows 10 Insider Preview, so heads up! It still works in Chrome and Firefox though - but it seems the rules above seem to cause the Assistant to not appear in Chrome. Still looking into this one.

Anyways, this screenshot should help. Setting width from 165px to 0px effectively fixes it, I believe.

http://i.imgur.com/DUpFQCN.png
 

Alex302

Filters Developer
Staff member
Administrator
It's broken in Edge again on Outlook when using the latest Windows 10 Insider Preview, so heads up! It still works in Chrome and Firefox though - but it seems the rules above seem to cause the Assistant to not appear in Chrome. Still looking into this one.

Anyways, this screenshot should help. Setting width from 165px to 0px effectively fixes it, I believe.

http://i.imgur.com/DUpFQCN.png
Could you please make rules like in post #2? I can't do anything in Egde, it is indescribably slow on my pc.
 

Alex302

Filters Developer
Staff member
Administrator
Please check:
Code:
outlook.live.com#$##primaryContainer > div[style="overflow: hidden; position: absolute; top: 50px; right: 165px; bottom: 0px; left: 0px; height: auto; width: auto;"] { width: 100%!important; }
outlook.live.com#$#div[class="_n_h"][style$="height: auto; width: 165px;"] { display: none!important; }
 

Boo Berry

Moderator + Beta Tester
Moderator
Unfortunately I'm not any good at creating rules like that. :p

EDIT: No go with those rules. Hmmm, time to clear the cache. Blah, cursed Edge.
 

Alex302

Filters Developer
Staff member
Administrator
Added to Annoyances filter:
Code:
outlook.live.com##div[class="_n_h"][style*="width: 165px;"]
outlook.live.com#$##primaryContainer > div[style*="right: 165px;"] { width: 100% !important; }
Please, check the result.
 

Boo Berry

Moderator + Beta Tester
Moderator
There's a new Outlook beta with an anti-adblock message on the right side (as always). That leftover ad/anti-adblock space on the right side will need collapsed as well. Looks to me they're beginning to randomize elements now, which makes it a little harder to block. Also can't drag the Assistant anymore on the beta Outlook site @avatar and @vasily_bagirov

Access the beta from here (probably need a US VPN/account): https://outlook.live.com/mail/#/inbox
 
Top