[Resolved]Spotify Windows App (Premium) Slow to switch tracks and update album art of currently playing track

Status
Not open for further replies.

ChickenSalad

New Member
Using AdGuard for Windows, spotify app is slow to change tracks (~3 seconds) and slow to update the album art of the currently playing track once it has changed (another ~3 seconds after the song changes).

When I turn AdGuard to "Protection is disabled" the track changes near instantly (< 1 second) and the album art updates as soon as the track changes.

Spotify is not in my list of apps under the Network -> Automatically filter appliction traffic "List of filtered applications".

I have tried turning almost all settings "off" in AdGuard to isolate what exactly might be causing the issue, but I cannot identify a setting that I can change that resovles the issue, other than turning AdGuard to "Protection is disabled".

Any guidance is appreciated.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
@ChickenSalad
Hello there!

While checking your request, we managed to find out that filtering for this application still works, despite the fact that it is in the default filtering exceptions.
The developers have been informed. Presumably, the fix will be released in version 7.3.
Here is a link to the issue on GitHub.
Thank you for the information provided.
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
Please check if you have tried to exclude the Spotify application from filtering by entering the path:
%Localappdata%\Blitz\current
As our developers have advised.
 

ChickenSalad

New Member
I believe this is what you're referring to. I assume unchecking an app, should exclude it?
I'm still experiencing extreme slowness with these settings vs turning AdGuard off completely.
AdGuard_Spotify.png
 

Feardex

New Member
This does not work, I've tried everything, excluding Spotify folder, adding Adguard dns to my network adapter, putting it on nightly (most recent version). I'm on Adguard 7.3 and nothing seems to be working, I have Spotify premium and it's very annoying that if I want to use Spotify I have to turn off Adguard in order to listen properly without any delay whatsoever.

(I FIXED IT, READ MY NEW COMMENT)
 
Last edited:

Feardex

New Member
I fixed it by going Settings -> Network.
Check "Use WFP network driver" and scroll down to HTTPS filtering and click on "Reinstall Certificate".
If any of these don't work, add the following IP addresses to your DNS server addresses to your network adapter:
176.103.130.130
176.103.130.131

This worked for me, I've finally found a solution.
 
Status
Not open for further replies.
Top