[Resolved] Video ads on https://www.news.com.au

Discussion in 'Missed Ads' started by ag_bug_finder, Apr 24, 2019.

  1. ag_bug_finder

    ag_bug_finder Beta Tester

    Joined:
    May 27, 2014
    Messages:
    1,720
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    4,215
    I'll move this to the correct forum section.
     
  3. ag_bug_finder

    ag_bug_finder Beta Tester

    Joined:
    May 27, 2014
    Messages:
    1,720
    Thanks.
     
  4. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,939
    Please check @Adam.
    Site requires Australian IP. Sadly normal url blocking and $replace on the two m3u8 files and vmap resulted in broken video.
     
  5. Adam

    Adam Filters Developer Staff Member Moderator

    Joined:
    Aug 17, 2014
    Messages:
    1,456
    Could you please check these rules:
    Code:
    ||ssaiplayback.prod.boltdns.net/playback/once/v*/vmap/hls/$replace=/(<VAST[\s\S]*?>)[\s\S]*<\/VAST>/\$1<\/VAST>/,domain=news.com.au
    ||ssaiplayback.*.boltdns.net/playback/once/v*/hls/*.m3u8$replace=/(#EXT-X-TARGETDURATION:[\S]*?)\n[\s\S]*?#EXT-X-DISCONTINUITY/\$1/,domain=news.com.au
     
  6. ag_bug_finder

    ag_bug_finder Beta Tester

    Joined:
    May 27, 2014
    Messages:
    1,720
    Perfect, working as expected.
    Please do add these immediately.
    Thank you.
     
  7. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,939
    Added both rules to Base filter.