Shadowsocks not working

Laitinlok

New Member
Try transparent proxy mode in Shadowsocks app, also I would recommend turning on DNS filtering and set DNS as Cloudflare with DNS over HTTPS. Make sure to turn on UDP with socks5 proxy in adguard app.
 

Smm.shadow

New Member
I had DNS filtering turned on and set with cloud flare.tried transparent mode, same thing. UDP over proxy also enabled.
What else can I do ?
Proxy over tor working just fine btw.
 

Laitinlok

New Member
Try turning off private DNS on your phone, it's causing issues because adguard doesn't route dns over proxy but the private DNS will route through the proxy which might cause some conflict
 

LoveAdguardLove

New Member
Thank you for this, I spent the entire afternoon trying to get ShadowSocks working until I followed @Laitinlok 's advice:

1. Ensure ShadowSocks App is disabled from Adguard Filtering
2. Settings -> Network -> Proxy -> ON, Set up a Shadowsocks Proxy:
SOCKS5, 127.0.0.1, 1080, Enable UDP Through Proxy
3. Settings -> DNS Filtering -> On -> Cloudflare Secure DNS (DNS-over-HTTPS)
4. ShadowSocks App -> Settings ->
Service Mode -> Transproxy
SOCKS5 proxy port - 1080
Transproxy port - (port for service)
5. Start up the ShadowSocks connection & Adguard

That did it for me, no issues now, everything seems to work.
 
Top