Should Adguard Assistant icon show on all web pages?

Discussion in 'Extensions (Userscripts)' started by shawn8888, Jul 7, 2018.

  1. shawn8888

    shawn8888 New Member

    Joined:
    Jul 7, 2018
    Messages:
    18
    Should Adguard Assistant icon show on all web pages?
    I am using firefox and adguard is set on proxy mode. Only about 20% web pages show the Adguard Assistant green icon at the right bottow.
    Is it normal?
     
  2. Norbert

    Norbert New Member

    Joined:
    Jul 7, 2018
    Messages:
    5
    same here ...

    Windows 10 Home (32-bit, Version 1803)
    AdGuard Windows (Version 6.2.437.2171)
    AdGuard Assistant (Version 4.1.12)
    Chrome (32-bit, Version 67.0.3396.99)

    example websites:
     
  3. shawn8888

    shawn8888 New Member

    Joined:
    Jul 7, 2018
    Messages:
    18
    If it is normal, why doesn't it work for most websites?
     
  4. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,140
  5. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,945
    In addition, the Assistant won't appear on heise.de regardless due to this rule in the Base filter; @@||heise.de^$extension

    @avatar said it's to workaround an issue with AG for Windows 6.2. Once 6.3 stable is out and everyone updates to it, they'll remove that filter and it'll work again. :)
     
  6. Norbert

    Norbert New Member

    Joined:
    Jul 7, 2018
    Messages:
    5
    I am not using the proxy mode ...

    www.heise.de -> still no Assistant icon!
     
  7. Norbert

    Norbert New Member

    Joined:
    Jul 7, 2018
    Messages:
    5
    oups .. reply in parallel .. thank you Boo! :)
     
  8. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,945
    The Assistant does show for me on golem.de though - this is with AG for Windows 6.3 RC though.
     
  9. shawn8888

    shawn8888 New Member

    Joined:
    Jul 7, 2018
    Messages:
    18
    For some reason I just can't get the "automatic" mode to work, so proxy is my only solution. Any idea when this corelibs version will be released?
     
  10. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,945
    You should probably contact support for that one, hopefully they can figure out why it doesn't work.
     
  11. shawn8888

    shawn8888 New Member

    Joined:
    Jul 7, 2018
    Messages:
    18
    Does 6.3 RC uses CoreLibs? Does it support https on proxy mode?
     
  12. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,945
    No, it's still several months out until it lands in beta. Probably a couple more months after that until it lands in stable. I wouldn't expect to see the CoreLibs-integrated version until the end of the year.

    Like I said, I'm sure the AG support and dev teams would be very interested why automatic mode doesn't work for you.

    But then again, ETAs and whatnot seem to be a jinx. :p
     
  13. Norbert

    Norbert New Member

    Joined:
    Jul 7, 2018
    Messages:
    5
    Strange ... now it works on my side too ...
     
  14. George Joerg

    George Joerg New Member

    Joined:
    Jul 8, 2018
    Messages:
    3
    sins about 4 Days the Adguard Assistant green icon is disappeared on www.wallstreet-online.de

    It started when I wanted to stop a banner and Adguard collapsed within 0.5 sec every time I tried to.
     
  15. shawn8888

    shawn8888 New Member

    Joined:
    Jul 7, 2018
    Messages:
    18
    I got the "automatic" mode working and the Adguard Assistant now shows on most pages. Thanks!
     
  16. George Joerg

    George Joerg New Member

    Joined:
    Jul 8, 2018
    Messages:
    3
    now it is Working again , the automatic or $jsinject was not the problem. I think the Server , Backbone from them had problems.
     
  17. lostcowboy

    lostcowboy New Member

    Joined:
    Nov 4, 2018
    Messages:
    7
    Adguard Assistant icon, ah thats my problem thinks. I'll turn it off.