Sideloading custom filters and settings onto Firestick - possible?

EnthusiastX

New Member
AdGuard can be sideloaded onto Firestick and it works well, but there are many custom rules I want added to block Amazon-specific ads and tracking. How can I do that? My Firestick isn't rooted and it appears there is no way to browse through storage with AdGuard to find files I pushed via ADB commands onto Firestick storage. Is it possible to allow storage browsing permissions to AdGuard via ADB commands? What would be those commands (remote, over network/IP).

Another issue I noticed is that custom Stealth Mode cannot be activated on Firestick. Only "High" mode can be activated. Why is that?
 

Chinaski

Support Marine
Staff member
Administrator
Moderator
Hello there!

You can try to add custom filters via entering URL to required filter.


About Stealth Mode and High level of protection - can you send a screenshot with the issue.

As for permission - You can try to use this commands:

./adb shell pm grant com.adguard.android android.permission.READ_EXTERNAL_STORAGE
./adb shell pm grant com.adguard.android android.permission.WRITE_EXTERNAL_STORAGE
 

EnthusiastX

New Member
I tried those commands for Adguard and for the generic Downloads and generic Files built-in apps. The commands worked for providing read and write permissions, but they didn't resolve the issue of not being able to select anything. There was nothing to select anyway.

ExportImport.jpg

ES File Explorer and Fire TV could not be selected. When I loaded ES File Explorer separately, it did show me plenty of files (Internal Storage). I think Firestick 4K was meant to be a semi-locked/closed system.

In Adguard Adblocker Stealth menu, only On/Off and High options could be selected. Firestick interface wouldn't allow me to navigate to select Ultimate or Custom options. Again, it could be a Firestick UI Navigation issue. Adguard was not designed for FirestickOS/FireOS.

I sideloaded Adguard VPN onto Firestick 4K, but couldn't use it because at first the screen would rotate 90 degrees back and forth. I just kept pressing Enter on the Firestick 4K remote and eventually got through and managed to login, navigation through options was impossible. On top of that, Amazon Prime detected Adguard's "Ninja" VPN as a VPN connection/proxy and didn't allow streaming. Other "dirty" VPN's didn't have that problem.
 
Last edited:

EnthusiastX

New Member
Browserleaks.com WebRTC test leaks TUN IP (one that is set in Low Level Advanced Settings) as local IP. I think it could be due to the Stealth Mode not working correctly. I was going to root my Firestick, install AdGuard as Local HTTP Proxy and use a separate VPN to spoof my IP, but it would be pointless if the local IP can't be hidden.

Is there a beta testing program for which I could sign up? Firestick version of AdGuard is needed and I would interested in testing Firestick-specific capabilities

BTW, when AdGuard runs as a local VPN, what protocol does it use? WireGuard?
 

EnthusiastX

New Member
I cleaned cache of all Firestick Apps and AdGuard began using ES File Explorer as default file browser. I navigated to JSON settings file and TXT filters file, but AdGuard wouldn't import either of them. AdGuard simply wouldn't change any settings and/or filters upon importation of files.
 
Top