Slow loading of web pages with AdGuard

zspl

New Member
I'm currently evaluating moving on from AM to Adguard so I'm running tests on couple of my computers.

On my laptop, ADGuard noticably slows down my internet connection in terms of loading web pages. Either IE or Chrome - on both it takes more time to start loading the page before the content will eventually show up.

Whenever I disable ADGuard, web pages load normally.

On PC, it's nothing like this, just business as usual.

Anybody experienced any issue like this?
 

Nameless

Beta Tester
Not noticed any issues here if your using wifi try with a wired connection.

I suppose it also depends on how many background tasks you have running and the age of the machine.
 

zspl

New Member
Thanks for response.

If I disable Adguard filtering, it works all fine. So why would background task, wifi/wireless connection or age matter in that case?

Also AM wasn't slowing down web page loading the way Adguard does.
 

Nameless

Beta Tester
They were just tests to see if the wifi was an issue, too many applications were running in the back ground or maybe the age of the machine were hitting performance thats all, im on my laptop now and have not noticed any difference between it or my pc.

laptop i5 4gb ram (wifi)
pc amd 8320 8gb ram (wired)

But any filtering application is going to slow down the loading of pages when its blocking stuff.
 

zspl

New Member
Well, just to confirm - i was comparing web page load time as laptop to laptop, not laptop to my pc. On the same machine I can see noticable difference in web page loading with Adguard filtering enabled.
 

Nameless

Beta Tester
Ok, well i can not help anymore but personally i noticed no difference.

I ditched admuncher months back and havent loked back, bad support and devs there.
 

avatar

Administrator
Staff member
Administrator
I'm currently evaluating moving on from AM to Adguard so I'm running tests on couple of my computers.

On my laptop, ADGuard noticably slows down my internet connection in terms of loading web pages. Either IE or Chrome - on both it takes more time to start loading the page before the content will eventually show up.

Whenever I disable ADGuard, web pages load normally.

On PC, it's nothing like this, just business as usual.

Anybody experienced any issue like this?
Hello!

Could be compatibility issue with some other software.

Three questions:
1. What antivirus do you use on laptop?
2. What network driver is used in Adguard (look at "Settings" - "Network" section)?
3. Windows version? Any other network software? Proxy?
 

zspl

New Member
Hello!

Could be compatibility issue with some other software.

Three questions:
1. What antivirus do you use on laptop?
2. What network driver is used in Adguard (look at "Settings" - "Network" section)?
3. Windows version? Any other network software? Proxy?


Hi,

thanks for response, here are my answers:

1. Symantec Endpoint Protection.
2. I tried with "Use WFP network driver" checked and unchecked - no difference (I did reboot after settings change), I have there also system-wide proxy set.
3. Windows 7 SP1 64bit. Yes I do have a system proxy, set in IE that apply to whole network on laptop. AdGuard is configured wit "Use system-wide proxy settings"

Thanks!
 

avatar

Administrator
Staff member
Administrator
One more question:
Do PC configuration (antivirus and proxy) differ from laptop?
 

zspl

New Member
One more question:
Do PC configuration (antivirus and proxy) differ from laptop?
Yes, my PC does have different antivirus (Kaspersky) and no proxy. Yet again, just to make sure - I'm not comparing PC to laptop, I'm comparing laptop to laptop (with vs without ADGuard filtering enabled).

Thanks!
 

avatar

Administrator
Staff member
Administrator
Thank you, we'll test Adguard in this configuration (Symantec + Proxy).
 

zspl

New Member
Thank you, we'll test Adguard in this configuration (Symantec + Proxy).
Thank you very much. Please let me know if you need anything more from my side or any logs or something.

Also I have 5.9 version, if you need I can install some sort of debug or beta software.
 

avatar

Administrator
Staff member
Administrator
Thank you very much. Please let me know if you need anything more from my side or any logs or something.
Adguard logs will be helpful in any case.

Please do the following:
1. Run Adguard in debug mode (find the shortcut in start menu)
2. Open Google Chrome and developer tools
3. Open "Network tab"
4. Open the web page that works slow usually
5. Right click on any place inside network tab and click "Save as HAR with Content"
6. Get our logs: https://kb.adguard.com/index.php?/Knowledgebase/Article/View/23/0/how-can-i-get-adguard-log-files
7. Send log files and HAR file to devteam@adguard.com
 

zspl

New Member
I have gathered the logs from long loading of two webpages and just send you to email address as above.

Hope this will help you shed some light on the issue.
 

avatar

Administrator
Staff member
Administrator
Avatar, did you guys got a chance to look into it?
I've created an issue in our bug-tracker but we have not yet worked on it.
We have tested your configuration (Symantec+Proxy) but everything was ok on our test machine.
I'll return with results of further investigation this week.
 

zspl

New Member
I've created an issue in our bug-tracker but we have not yet worked on it.
We have tested your configuration (Symantec+Proxy) but everything was ok on our test machine.
I'll return with results of further investigation this week.
THank you sir for you prompt response. Looking forward to hearing from you guys, I hope you will narrow down this issue. I would really love to stick to adguard on all my computers.
 

stoneyc

New Member
I disabled the wpf in network settings rebooted everything working fine now running windows 8.1 ie 11 Norton internet security running adguard version 5.10.1167.5997 first version of adguard 5.10 did not have the problem but after diableing wpf in this version then rebooting everything working fine adguard still blocks the ads
 

stoneyc

New Member
this is what I did I had same problem on 3 computers 2 running windows 8.1 64bit and 1 running windows7 32bit go to settings network uncheck use wfp network driver reboot right away or it wont work if you wait to reboot it wont work even after you reboot you will have to do it again but reboot right away don't no why but in buil number just before this last program update it never did his but in this one you have to do this
 

Dolfi

Banned
I have the same bc AG causes high CPU loads.
So if your laptop has a slower/weaker processor than your PC that might be the reason. Have a look at the taskmanager.
 
Top