[???] Social filters blocking good content.

Discussion in 'False Positives' started by streetwolf, Aug 14, 2014.

  1. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    Last edited by a moderator: Aug 14, 2014
  2. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    *Bumpity Bump* :)
     
    Last edited by a moderator: Aug 17, 2014
  3. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    22,961
    Hi
    Try this rule:
    Code:
    @@||platform.twitter.com/widgets.js$domain=bleacherreport.com
     
  4. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    Doesn't work for me. So far I'm batting 0% with the rules you have given me. Is there a problem on my end?
     
  5. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    22,961
    I don't know.
    Can you make a screenstot with the selected filters, or list them?
     
  6. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    I should have mentioned that I am using Fanboy's Social Media Filter list. Your filter does work if I use AG's Social Filter list and not FanBoy's.

    I posted on the Easylist forum about this problem and Fanboy stated that he had no problem with his list. I suppose he is using ABP. Perhaps AG is not converting FanBoy's filter correctly.

    I prefer FB's list because it filters out more social media stuff then does AG's social media list.

    btw... The background image is also filtered out. Why?
     
  7. offguard

    offguard Beta Tester

    Joined:
    Dec 12, 2013
    Messages:
    44
    Try this:

    Code:
    @@||twitter.com$domain=bleacherreport.com
     
  8. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    This works on FanBoy's list. Thanks.
     
  9. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    22,961
    The rule has been added to Experimental filter:
    Code:
    @@||twitter.com$domain=bleacherreport.com
     
  10. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    I have the Experimental Filter with the new rule but for some reason it doesn't produce the picture. Having it my User Filter works fine. My rule and the Experimental rule look identical. What's up?
     
  11. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    22,961
    Can you clean cache, remove this rule from User Filter and check again?
     
    Last edited by a moderator: Aug 19, 2014
  12. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    Unless there is an AG cache I'm not familiar with and you wanted that cleared I cleared my Firefox cache instead. This didn't do any good. However, I got the experimental filter to work by deleting the filter in my user filter and then I had to disable my user filter. After this the picture came back. I then re-enabled my user filter, with the filter in question, and all is fine now.

    It appears disabling my user filters was the key to get things working. Is this intended or perhaps it's a bug?

    Also as I mentioned already bleacherreport.com has a background image which AG blocks for some reason. What's up with this?
     
    Last edited by a moderator: Aug 19, 2014
  13. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    22,961
    What do you think about to get me access to Team Viewer for few minutes?
     
  14. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    ok, give me a moment to install it. I'll PM the key.
     
  15. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    22,961
    Please, try this rule
    Code:
    @@||outbrain.com^$domain=cnn.com
    The block "SPONSORED LINKS" is empty with disabled AdGuard(and with USA IP).
    If you find defects, make a screenshot, specify a problem area and put there.
     
  16. streetwolf

    streetwolf Beta Tester

    Joined:
    Apr 9, 2014
    Messages:
    500
    @@||outbrain.com^$domain=cnn.com does not work.
     
  17. Alex302

    Alex302 Filters Developer Staff Member Administrator

    Joined:
    Jul 20, 2012
    Messages:
    22,961
    Try this rules:
    Code:
    !!remove AROUND THE WEB on the main page
    cnn.com##.cnn_bin.bin_4
    !!remove SPONSORED LINKS on the main page
    cnn.com##.cnn_bin.bin_12
    !!remove "From Around the Web", bottom
    cnn.com##.ob_dual_left
    !!remove "From Around the Web", rigth
    cnn.com###outbrain_widget_3
    !!remove "Recommended by OB" bottom
    cnn.com##.ob_what
    !!unblock "POPULAR ON FACEBOOK" in international edition
    @@||facebook.com/plugins/activity.php?$domain=cnn.com
    cnn.com#@#.class="clearfix mbs pas hidden_elem"
     
  18. fanboy

    fanboy Member

    Joined:
    Oct 3, 2014
    Messages:
    110
    That is correct, blocking twitter outright will cause many false positives. Easier to just not to block it.