[Solved] Custom DNS Screwed up on Version 7.7

I'd been using DNS-over-TLS with a custom NextDNS address (https://nextdns.io/) happily and successfully before version 7.7. Then, yesterday, I upgraded to version 7.7, and decided to try out DNS-over-QUIC, since it was one the new features.

Navigating to Settings -> DNS Protection and scrolling down to "Custom DNS Servers," I switched my NextDNS custom server from tls:// to quic://. Well, after browsing for a few hours, I experience slowness and disconnects (a lot of HTTP 404 requests). So I decided to switch back to tls://, like I'd been using for many months. All I had to do was to edit quic:// back to tls:// It should be no problem, right? Wrong:


Can someone please explain to me how tls:// is somehow now an invalid address, when the only thing that changed was the protocol? I didn't change the address, only the protocol! Now, somehow it's not accepted! But when I use the same address, but with quic://, it's accepted! Is this a bug?


Quality Assurance
Staff member

Most likely, the address you added is no longer valid. Can you write us which address you want to add so that we can check it?
Thank you for your reply. I've sent you a message with the information you requested. Though, I don't think that the address is invalid, since I can use it with quic:// just fine, but only with tls:// it registers as "invalid." But even so, with AdGuard versions before 7.7, it was working perfectly as tls://. So I strongly doubt that it's an invalid address.

EDIT: Also, AdGuard for Android -- which I've been using for years as well -- doesn't have this problem. I can still use tls:// with the NextDNS address. So I'm almost certain that this is a bug with Android 7.7 for Windows.
Last edited:
When I try to switch custom DNS providers, I have even more problems. AdGuard kills my Internet connection; I can't connect to any websites, and instead get HTTP 404 errors. This happened when I tried to switch to Quad9, and it happened twice. In both times, the AdGuard service itself actually froze; I couldn't pause protection, and ultimately the notification area icon turned yellow with an exclamation mark, and I received a message that there was a problem starting the service. I had to restart my computer to restore my Internet connection.

Even after restarting, my custom DNS settings -- Quad9 over TLS -- didn't take effect right away. I tested the DNS by following the instructions on this webpage, and the test failed. I had to restart the program completely in order to get DNS filtering working. So there seems to be some problem with DNS filtering, at least on my computer.

EDIT: After some more testing, it seems that custom DNS with HTTPS works fine, as does DNSCrypt. If I switch to AdGuard DoH or AdGuard DNSCrypt, then the AdGuard DNS homepage can correctly detect that I'm using AdGuard DNS. Same thing with NextDNS; if I use DoH with a custom NextDNS address, then it works fine, and the AdGuard program will accept the custom URL. But again, for some reason, the program doesn't accept the tls:// version of the same URL.
Last edited: