[Solved] How to use Adguard Home on Win10 machine as DNS server for network?

Sander_Bouwhuis

New Member
I have Adguard Home installed on my Windows 10 machine (192.168.1.128) and it works perfectly.

Now, I want every other machine on my network to use my Windows 10's Adguard Home as a DNS server.
All my devices connect to my router, and I set the router to have my Windows 10 machine as the DNS server.

Router.png
But, in Adguard Home I see no requests come in from other devices, and other devices can no longer resolve any addresses.

Statistics.png

I also tried opening port 53 as inbound rule in the firewall of the Windows 10 machine, but to no avail.

What am I missing or doing wrong?
 

Blaz

Moderator & Translator
Staff member
Moderator
If you run ipconfig /all on the other devices, is it showing the correct address?
Did you setup your Win10 device as static ip address on router or manually in Win10?
 

Sander_Bouwhuis

New Member
All my devices point to the default gateway which is the DD-WRT router on 192.168.1.1. The router also functions as the DHCP server for my network.
So, apparently, the router tries to contact 192.168.1.128 where Adguard Home runs, but gets no (proper) response. Therefore, the router falls back to secondary DNS. If I turn off the secondary DNS, no device on my network functions anymore.
 

Blaz

Moderator & Translator
Staff member
Moderator
Possible the other devices still have previous lease with old DNS.
Try to set DNS manually in other devices and see what happens.
 

Sander_Bouwhuis

New Member
No, ipconfig/all shows the correct DNS server (it doesn't matter whether I set it to the router or to the Adguard Home computer).

I set the DNS server on another Windows 10 machine to 192.168.1.128, but no DNS records are resolved. Somehow other devices cannot reach the computer with Adguard Home on it. But, when I go to Windows Explorer, I can make a network share to it, so the computer is reachable.

Are you sure there are no ports or firewall things I have to change? Or is there a setting I need to change to make Adguard Home actually listen on port 53 for incoming DNS requests from other computers?
Or could it be something I have to change in the DD-WRT router to make requests go to Adguard Home?
 

Blaz

Moderator & Translator
Staff member
Moderator
Not that I am aware of, ieverything else in AdGuard Home is in default. If you completely disable firewall on Windows 10, does it work then?
 

Sander_Bouwhuis

New Member
Yes! Then it works!

It turns out that you need to open BOTH TCP and UDP ports 53 in your firewall for Adguard Home to function as a DNS server.

Blaz, thank you, Thank You, THANK YOU!!!!!!
 
Last edited:

Sander_Bouwhuis

New Member
1. Press <WIN+R> (or open a command prompt) and start this : %windir%\system32\WF.msc
1. Open Firewall settings.png

2. Click on 'Inbound rules in the top left, and then on New rule in the top right:
2. Add inbound rule.png

3. Choose Port:

3. Choose port.png

4. Choose TCP and set the port nr to 53:
4. Choose TCP 53.png

5. Choose Allow the connection:
5. Choose Allow the connection.png

6. Choose all locations:
6. Choos locations.png

7. Give it a descriptive name:
7. Firewall rule name.png

8. Now do the same thing for UDP (replace TCP in step 4 with UDP).
9. Done!
 
Top