[SOLVED] Windows 7: AdGuard for Windows cannot be started/installed - d3dcompiler_47.dll is missing

Discussion in 'Technical Support (AdGuard for Windows)' started by Anonymer-User, May 16, 2017.

  1. Anonymer-User

    Anonymer-User New Member

    Joined:
    May 16, 2017
    Messages:
    4
    Hello,

    I have Windows 7 Pro 64bit and suddenly I neither can start, nor can I install, uninstall or update AdGuard anymore (regardless if latest stable release or beta), everytime I try to start or install it, I get a message saying that AdGuard can't be installed due to a missing d3dcompiler_47.dll file ?!
    Please help!
     
    Last edited: May 17, 2017
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,948
    That's strange, I didn't know Adguard required DirectX.

    Got a screenshot of the error?
     
  3. Anonymer-User

    Anonymer-User New Member

    Joined:
    May 16, 2017
    Messages:
    4
    [​IMG]

    It's german saying: setup.exe - system error: The application cannot be started, because D3DCOMPILER_47.dll is missing on this computer. Install the application again, to solve the problem.
     
  4. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,903
  5. Anonymer-User

    Anonymer-User New Member

    Joined:
    May 16, 2017
    Messages:
    4
    I have already done that - 'standard uninstall', should I try 'advanced uninstall'?
     
  6. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,903
  7. Anonymer-User

    Anonymer-User New Member

    Joined:
    May 16, 2017
    Messages:
    4
    I found the resolution / fix for my problem! (KB4019990) :) - it installs the missing D3DCompiler_47.dll file (version 6.3.9600.18611) in the corresponding system folder
    (System32 - Filesize: 4.1 MB / SysWOW64 - Filesize: 3.39 MB).

    https://support.microsoft.com/en-us...tallation-is-blocked-on-windows-7-windows-ser
    It affects only Windows 7, NOT Windows 8/8.1 or 10.


    For all others who have the same problem, here the direct links for the KB4019990 Microsoft patch:

    Meanwhile I'm quite sure the reason why this problem occured was the installation of the new Unigine 3D Benchmark 'Superposition'. https://benchmark.unigine.com/superposition

    While I had this problem before I fixed it, I was not only not able to start or (re-)install AdGuard, but I also was not able to start the installed Garmin update application (Garmin Express) for my car navigation by the way.
     
    Last edited: May 18, 2017
  8. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,903
    @Anonymer-User thanks for the detailed update, glad you solved the issue.
     
  9. axanh

    axanh New Member

    Joined:
    Oct 28, 2017
    Messages:
    2
    encounter this problem too .. now solved thanks