Some sites display a blank page.

streetwolf

Beta Tester
Certain sites just display a blank page. If I disable AG they display fine. Here is an example: http://www.rbmc.org/meridian-health-announces-plans-merge-raritan-bay-medical-center/. I disabled all filters and extensions but that didn't help. Only disabling AG seems to work.

IE11 works fine with AG enabled.

******
Here's info from my Program log. What is happening?

Address: http://www.rbmc.org/meridian-health-announces-plans-merge-raritan-bay-medical-center/
Time: 03/12/2015 17:56:33
Status: The page has been filtered
Request details:

New element hiding rules have been added to the page
Popup blocking code has been added to the page

Bytes received: 60067
Bytes sent: 364
 
Last edited by a moderator:

vasily_bagirov

Administrator
Staff member
Administrator
Hi!
Can you give more details on the problem and your Adguard settings?
I wasn't able to reproduce the problem - website opens as usual. You mentioned there are other websites with same problem, what are they?
 

streetwolf

Beta Tester
Just narrowed it down. It's the WFP network driver that is causing the pages not to display. Pages display fine when I don't enable the WFP network driver. IE11 works fine with the WFP driver enabled.
 
Last edited by a moderator:

streetwolf

Beta Tester
Are you running under Windows 8.1 x64 with the latest patches from the last patch Tuesday? Also, are you running the version of Fx in my link a few posts above? As mentioned, disabling the WFP driver makes the site work so make sure you have it enabled during your testing.

If you are running a different version of Windows this could be why you can't reproduce it. I have no problem doing so with a brand new Fx profile.

I'm also getting SSL connection issues where I have to add these HTTPS sites to the HTTPS exclusion filtering list. Just seems like a lot of things are just not working like they did a few releases back. Perhaps some Version 6 code is now in the latest betas and is causing my problems??
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
I am using the latest Windows 8.1 64-bit. Honestly, it sounding like you may need to manually add the certificate to Firefox.
 

streetwolf

Beta Tester
I am using the latest Windows 8.1 64-bit. Honestly, it sounding like you may need to manually add the certificate to Firefox.
How do I go about doing this BB?

---------- Post added at 05:27 PM ---------- Previous post was at 04:43 PM ----------

Here's a site I'm getting a 'secured connection failed' message when I use the WFP driver ... https://www.myretirement.sanofi-aventis.us/ The TDI driver adgnetworktdidrv works fine.

There must be some debugging I can do to find out what my problem with the WFP driver is. I never had problems like this before the last beta or maybe the one before that.
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
I get the untrusted connection error on that site in normal Firefox, Chrome, etc. regardless of TDI/WFP drivers. Looking at the technical information, I can see why in this case.

www.myretirement.sanofi-aventis.us uses an invalid security certificate.

The certificate expired on 9/3/2014 7:00 AM. The current time is 3/14/2015 4:36 PM.

(Error code: sec_error_expired_certificate)
As for manually importing the certificate, the tutorial is located here: https://kb.adguard.com/index.php?/Knowledgebase/Article/View/29/10/filtering-support-for-https-connections-in-portable-browsers

If the Adguard CA certificate exists already in the certificate manager in Firefox/Nightly, I do advise deleting it, exiting and restarting Firefox/Nightly then finish the tutorial by manually importing the current certificate.

---------- Post added at 04:48 PM ---------- Previous post was at 04:40 PM ----------

Yeah, I just cleared out my SSL temp directory (located under %ProgramData%\Adguard\NetworkTemp\SSL or C:\Adguard\NetworkTemp\SSL in my case) and that site now works. If all else fails, close Adguard, kill Adguard.exe and AdguardSvc.exe in the Task Manager, go to that folder and delete everything inside. Then reboot the PC and Adguard should create a new certificate. You *may* have to repeat the process in the tutorial (or you can delete the certificate in Nightly's certificate manager) before killing Adguard and cleaning out the SSL folder.
 

Boo Berry

Moderator + Beta Tester
Moderator
I added more to my previous post.

---------- Post added at 04:56 PM ---------- Previous post was at 04:53 PM ----------

Okay, I think I can confirm this issue with the WFP driver and ironically the TDI driver too IF I don't first clean out the SSL temp folder between driver switches. For whatever reason that site you posted last won't work while the WFP driver is being used regardless of browser. Looking at the technical details, again, I see the following error;

www.myretirement.sanofi-aventis.us uses an invalid security certificate.

The certificate expired on 9/3/2014 7:00 AM. The current time is 3/14/2015 4:53 PM.

(Error code: sec_error_expired_certificate)
Looks like the certificate has the wrong date. Not sure, more testing is needed.
 

streetwolf

Beta Tester
There is a file in my Fx profile called 'cert_override.txt' Looking through it it contains the sanofi-avantis.us site. I think I got a message at some point that let me add this site to this list in order to get it working.

I'm still at a loss why the very first site I posted only works with TDI.
 

Boo Berry

Moderator + Beta Tester
Moderator
Enable the WFP driver, reboot then look at Adguard's SSL temp folder located at C:\Adguard\NetworkTemp\SSL and delete all files within, except Adguard CA (which is a .cer file) and Adguard CA.pvk and try these sites again with the WFP driver. If you encounter the error, look again within the SSL folder whether or not and .x files exist within.
 

streetwolf

Beta Tester
I did as you outlined above. When I went to the sanofi-aventis site I got the connection message but when I hit the 'Try Again' button it got me into the site. I restarted Fx a few times and each time I could access the site. In the AG SSL folder I now have the file '38.98.197.78_443_www.myretirement.sanofi-aventis.us.x.' which is zero length.

There is also a test.cer and test.pvk file in the SSL folder. Are these supposed to be there?
 
Last edited by a moderator:

Boo Berry

Moderator + Beta Tester
Moderator
Delete 38.98.197.78_443_www.myretirement.sanofi-aventis.us.x and it *should* work fine with the WFP driver. In fact, delete any .x files you see.

Yes, those are supposed to be there.
 

streetwolf

Beta Tester
Deleted the .x files, rebooted and went to my sanofi-aventis page. Got the same message "Secure Connection Failed", pressed 'Try Again' and I got into the site. Once again '38.98.197.78_443_www.myretirement.sanofi-aventis.us.x' appears in my SSL folder. It seems I need it.

---------- Post added at 06:37 PM ---------- Previous post was at 06:27 PM ----------

I have a file in my Fx profile called 'cert-override.txt'. It contained my sanofi-aventis site. I deleted it for testing purposes and rebooted my machine. When I got into Fx and went to the site I first got the Connection Failed message. I clicked on Try Again and then I got an Untrusted message for the site. I clicked on the button to add it as an exception which is now in the 'cert-override.txt' file. Everything now works fine. So in my case I need the .x file in AG and the exception in Fx.

btw... after I posted this message I tried to go to http://www.rbmc.org/. It displayed fine but when I display it again all I get is a blank page.

---------- Post added at 06:47 PM ---------- Previous post was at 06:37 PM ----------

I now can get to rbmc.org as long as I enter it as https://www.rbmc.org/. Why does the WFP driver require https and the TDI filter let's me use http??
 
Last edited by a moderator:

streetwolf

Beta Tester
This is getting ridiculous. My sanofi-aventis .x file in my SSL folder get's deleted when I restart my computer. This causes the Connection Failed message to appear again. I must click on Try Again to access the site.

I had to add the site to the https exclusion list in order to get to the site consistently.
 
Top