SONOS stopped working

Discussion in 'Technical Support (AdGuard for Android)' started by steve1209, Jan 3, 2015.

  1. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    491
    Hi,

    My SONOS controller app on my Android Tab 4 won't work when Adguard is enabled. It works again when I disable Adguard. I even tried disabling all filters in Adguard, it still fails. Using V 1.1.811
     
  2. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Hi!

    We need full app log to check what's the problem.

    Could you please do the following:
    1. Switch "Logging level" to "Record everything" in Adguard's advanced settings
    2. Reproduce the issue
    3. Switch "Logging level" back to default
    4. Send us a message from the app (select "Send feedback" in the app menu).
    5. Post ticket ID here
     
  3. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    491
    I didn't get a ticket ID but info was sent with description of Sono's problem

    Edit:

    Just got it
    Ticket ID: XUE-435-12029
    Subject: [Adguard for Android] Custom
    Department: English-speaking Support
    Type: Issue
    Status: Open
    Priority: Normal
     
  4. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    It seems that Sonos is not compatible with how Android VPN works.

    The problem is that in Android when VPN is enabled it restricts ALL incoming connections.
    Also it seems that Sonos work relies on incoming connections.

    Android devs do not want to fix this, for some reason they think that it's not a bug but feature.

    Possible workaround: you can use Proxy mode. If you have ROOT access it is rather simple.
    If not you'll have to setup proxy settings for each Wi-Fi connection you use.
     
    Last edited by a moderator: Jan 18, 2015
  5. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    491
    Hi Avatar,

    Thanks for looking into this much appreciated! I don't have root, so can you explain in a little more detail how to set up a proxy for my Wi-Fi connection, I'm not sure of the procedure or steps, it would most likely only be for my home Wi-Fi since I seldom travel with my tablet!
     
  6. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    We have detailed instruction in the FAQ section of the app ("how to setup proxy manually").

    In a few words:
    Switch filtering mode and proxy setup mode in Adguard's advanced settings, then open your Wi-Fi settings and set proxy to host=127.0.0.1 and port=8080
     
  7. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    491
    Hey Avatar,

    I tried looking thru FAQ for Android, http://adguard.com/en/faq.html#betterAndroid if thats where I should have been looking, but didn't see any info on setting up proxy? Your few words got me going though, SONOS is now working on my Android Tablet, as ALWAYS thank you Very Much for your assistance!
     
  8. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    I meant the FAQ that is inside the app (tap help icon in apps action bar).
     
  9. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    491
    OK thanks, see it clearly now LOL!
     
  10. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Steve, hi again!

    We've just released new beta version of Adguard - 1.1.818.
    In this version we've excluded local network from VPN filtering so now your Sonos issue should be fixed.

    Could you please check Adguard in VPN mode with Sonos?
     
  11. steve1209

    steve1209 Beta Tester

    Joined:
    Mar 31, 2014
    Messages:
    491
    Hey Andrey,

    I installed 818 today, I dropped back from HTTP filtering to VPN and I can confirm Sonos is working just fine with VPN. I'm still hopping for a fix for the NBC App (I know you are looking at it), I'm going to try it again, see if anything changed there! Oh BTW Sonos was working just fine with HTTP but now it works on VPN as well!
     
  12. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Great, thank you for checking it!