Stealth Modifier Not Being Honored in User Filter

Timmy256

New Member
Hi, I hope you are doing well.

I'm running AdGuard 2.3.2.710 on Mac Mojave and I've noticed that the filters I've added to my user filter list, using the stealth modifier (copied and pasted straight from documentation; in order to allow stealth to skip in those websites), is not working. I remember this working when I was on Windows, but on Mac, it doesn't seem to work.

I open the filtering log and see that any website I've tried to filtered using that modifier is getting filtered anyway. It's like if the engine is not respecting the whitelist for those sites when picking them for filtering.

This really messes up my workflow, as I like to keep all the Stealth checks activated in Settings for filtering and manually create a User Filter to allow certain problematic sites. But, while working like this, I need to disable AdGuard / disable Stealth from settings before navigating any of those sites.

Could you please let me know if there might be something going on there and if there is something I can do to fix this?

Thanks in advance for your help.
 

Timmy256

New Member
Hi Slvvko, thanks for your reply.

It happens when joining a Google Meet meeting. With all the Stealth checks activated, the call joins and after a couple of minutes it exits with an error message. If I disable the WebRTC blocking it works.

I've tried adding @@||meet.google.com^$important,document,~extension and @@||meet.google.com^$stealth. From looking at the filtering log, when I join the meeting, also chat.google.com gets contacted, so I added it with the same rules as above. Also, I noticed two IPs (not named domains) in the filtering log, over and over while the meeting lasts, being blocked with the WebRTC check. I've even tried adding those two with the stealth modifier and they still get blocked by WebRTC. All these addresses I'm mentioning (meet.google.com, chat.google.com and those two IPs), even after adding the user filters to not filter stealth, keep appearing in the filtering log as blocked when some stealth component has to kick in.

The concrete question is then, why if I add those examples to my User Filter list, to not filter stealth, they keep showing in the filtering log as being blocked by WebRTC (and other stealth checks that might come up)?

Please let me know if there's anything else you need from my side.
 

slvvko

Filters Developer
Staff member
Administrator
Moderator
sorry for so late response

could you please specify what exactly user rules you tried?
 

Timmy256

New Member
Hi Slvvko, I mentioned them in my third post:

I've tried adding @@||meet.google.com^$important,document,~extension and @@||meet.google.com^$stealth. From looking at the filtering log, when I join the meeting, also chat.google.com gets contacted, so I added it with the same rules as above. Also, I noticed two IPs (not named domains) in the filtering log, over and over while the meeting lasts, being blocked with the WebRTC check. I've even tried adding those two with the stealth modifier and they still get blocked by WebRTC. All these addresses I'm mentioning (meet.google.com, chat.google.com and those two IPs), even after adding the user filters to not filter stealth, keep appearing in the filtering log as blocked when some stealth component has to kick in.
Thanks for your help; please let me know what you think
 

silicaji

New Member
Hi Slvvko, thanks for your reply.

It happens when joining a Google Meet meeting. With all the Stealth checks activated, the call joins and after a couple of minutes it exits with an error message. If I disable the WebRTC blocking it works.

I've tried adding @@||meet.google.com^$important,document,~extension and @@||meet.google.com^$stealth. From looking at the filtering log, when I join the meeting, also chat.google.com gets contacted, so I added it with the same rules as above. Also, I noticed two IPs (not named domains) in the filtering log, over and over while the meeting lasts, being blocked with the WebRTC check. I've even tried adding those two with the stealth modifier and they still get blocked by WebRTC. All these addresses I'm mentioning (meet.google.com, chat.google.com and those two IPs), even after adding the user filters to not filter stealth, keep appearing in the filtering log as blocked when some stealth component has to kick in.

The concrete question is then, why if I add those examples to my User Filter list, to not filter stealth, they keep showing in the filtering log as being blocked by WebRTC (and other stealth checks that might come up)?omegle

Please let me know if there's anything else you need from my side.
I have the same issue but i watched some videos and my issue has been resolved.
 
Last edited:

slvvko

Filters Developer
Staff member
Administrator
Moderator
@Timmy256 unfortunately I can not reproduce the issue at my end

is it comfortable for you to provide remote access for checking/solving that?
 
Top