Stubborn notification refuses to be blocked?

David M

New Member
Adguard seems to have trouble blocking the notification from foxnews.com as shown below. It takes a few seconds for it to appear. I have both Adguard web and Adguard for windows installed.

1640319524949.png
 

David M

New Member
Sorry for the late response as I thought AG would inform my email. Anyways, I hadn't enabled the annoyances filter but have enabled all 4 filters now and it doesn't seem to help, unfortunately. The annoying notification still pops up.

It can be eliminated by giving in to its demands of disabling AG filtering bit the website then loads slowly with all sorts of ads and stuff.
 

Blaz

Moderator & Translator
Staff member
Moderator
Sadly I cannot reproduce. Please try this rule in user filter:

@@||foxnews.com^$generichide
 
Last edited:

David M

New Member
@||foxnews.com^$generichide
It said invalid rule. Add another @ at the beginning?

Edit: ...Added it. No errors but annoyance is still in place. Am I supposed to reboot the computer for each change I make to the rules or any AG setting?
 

Blaz

Moderator & Translator
Staff member
Moderator
Yep, another @. Restart is not required.

You are testing with which exact filters? From the US? DNS filtering active?

Trying to reproduce, so I can give exact rule.
 

Blaz

Moderator & Translator
Staff member
Moderator
According to screenshot DNS protection is not active.

Sadly with those information I still cannot reproduce. Even if I force an adblock detection value I get no popup :(

Please check with this rule:
Code:
foxnews.com#%#//scriptlet("set-constant", "AD_BLOCK_ENABLED", "false")
Alternate rules to try:
Code:
@@||static.foxnews.com/static/v/all/js/ads.js$domain=foxnews.com,important
@@||global.fncstatic.com/static/v/all/js/ads.js$domain=foxnews.com,important
 

Boo Berry

Moderator + Beta Tester
Moderator
I can't reproduce this and I'm in the US too.

However, what you should do is try disabling some filters one-by-one and forcefully refreshing the webpage (F5 on Windows) or clearing the cache and loading the page again. Maybe you can narrow down which filter list could be causing this detection.
 
Top