Technical issue with Firefox and HTTPS sites

Discussion in 'Discussion (AdGuard for Mac)' started by Vesta, Jan 2, 2018.

  1. Vesta

    Vesta New Member

    Joined:
    Jan 2, 2018
    Messages:
    2
    Hi!

    System details: macOS 10.13.2, Firefox 57.0.3, AdGuard 1.5.3.

    The issues is that Firefox and AdGuard do not work together. When AdGuard is enabled, Firefox cannot load HTTPS sites, like google.com and this forum. Please see screenshot below:

    [​IMG]

    Thanks!
     
  2. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,356
    Try closing Firefox and AdGuard for Mac (via the system tray icon in the top right of the screen in the menu bar) and reopening AdGuard for Mac (keep Firefox closed until AG for Mac starts - wait like 10 seconds after it appears in the upper system tray) or simply reboot the Mac so AG for Mac can install the needed certificate into Firefox.
     
    Vesta likes this.
  3. Vesta

    Vesta New Member

    Joined:
    Jan 2, 2018
    Messages:
    2
    Many thanks Boo Berry, problem solved!

    I installed Firefox after AdGuard and did not realize that AdGuard needs to install supporting files for Firefox.
     
  4. Tricia

    Tricia New Member

    Joined:
    Aug 25, 2016
    Messages:
    1
    This is the same error that I am also getting.
     
  5. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,356
    Close Firefox completely (make sure it's not running in the Dock) and reboot the Mac.