troubleshoot 5.10.1186 with Asustor Control Center.exe

Discussion in 'Technical Support (AdGuard for Windows)' started by Arniceous, Jan 2, 2015.

  1. Arniceous

    Arniceous New Member

    Joined:
    Jan 2, 2015
    Messages:
    8
    Adguard currently blocks the fallowing:

    1) ASUSTOR Control Center.exe NAS Login.
    2) Renders all mapped drives to the NAS as no longer active.
    3) HP Photosmart 6510 Scan to PC utility will become inactive.

    These key components are not html based with an assigned url or DNS configuration if you will. Rather imbedded exe's that have been blocked. We need these items to work or we will be forced to discontinue such a great product.
     

    Attached Files:

    Last edited by a moderator: Jan 4, 2015
  2. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
  3. Arniceous

    Arniceous New Member

    Joined:
    Jan 2, 2015
    Messages:
    8
    Sorry I don't quite understand your point. The installer library and application extention are the only two .dll present in libs. This application used to work bebore your last update than it started blocking all these services listed in my above thread. your link points me to a dropbox account .
     
  4. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    I mean you should copy/paste these files to Adguard's directory (Program Files (x86)\Adguard), not libs folder, sorry for confusing you.
     
  5. Arniceous

    Arniceous New Member

    Joined:
    Jan 2, 2015
    Messages:
    8
    I replaced all files listed in the dropbox location with my own in adguard x86 and restared the application. My above programs and services are still being blocked and there is no way to add an exception. As I stated earlier Adguard was not conflicting and working fine before the last major update. You guys wrote something that changed monitoring on the system-side.
     
  6. Dolfi

    Dolfi Banned

    Joined:
    Nov 21, 2014
    Messages:
    218
    Hi Ösi,
    The app is only for config. The work is done by AG service which you needed to restart. BTW: If you enable builtin logging (Protection | Log): What does AG say it does? Does it the same /w and w/o these WPF drivers (Settings | Network)?
     
  7. Arniceous

    Arniceous New Member

    Joined:
    Jan 2, 2015
    Messages:
    8
    okay I've located the log file Ide like to send it to a programmer here is one line item in reference to my issue:

    tcpConnected id=46653 flag=2 pid=22984 direction=out local=192.168.1.115:37218 remote=54.225.90.95:80
    Process: C:\Program Files (x86)\ASUSTOR\Control Center\LiveUpdate.exe


    Tue Jan 06 11:01:38 2015: Contents:
    GET /client/webapp/client/External.wmt?url=http://forum.adguard.com/showthread.php?3782-troubleshoot-5-10-1186-with-Asustor-Control-Center-exe&p=40161 HTTP/1.1
    Accept: text/html, application/xhtml+xml, */*
     
    Last edited by a moderator: Jan 6, 2015
  8. Dolfi

    Dolfi Banned

    Joined:
    Nov 21, 2014
    Messages:
    218
    LiveUpdate should neither be filtered at all nor the reason your software doesn't work (same issue as /w AG vs AG-svc), so the line is not helpful at all.
    But you might first simply want to disable all 'browsers' you do not use (Settings | Browsers | XYZ --> Don't filter)
    totally unrelated to above tcpconnect and the issue, as that line shows opening AG forum.
    I in your place stopped all other programs on your PC, cleaned the logs, enabled logging, opened ACC, waited for the error to show and then posted complete logs. Two in any way unrelated (to each other as well as to the issue) entries won't help too much, I'm afraid.

    Sorry to have no better news, Dolfi


    @avatar: Please see my related feature request
     
  9. Dolfi

    Dolfi Banned

    Joined:
    Nov 21, 2014
    Messages:
    218
    @Arniceous: Meanwhile you might want to configure AG to act as HTTP proxy and your browsers to use it.
    I bet that way you can work and use your NAS as usual.

    edit:
    @avatar: You sure AG acts only as HTTP proxy and not as HTTPS proxy too? Shouldn't that line be Use Adguard as an HTTP(S) proxy?
     
    Last edited by a moderator: Jan 7, 2015
  10. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Can you send the log file to me in PM?
     
  11. Arniceous

    Arniceous New Member

    Joined:
    Jan 2, 2015
    Messages:
    8
    98meg log file seems a bit too much to paste here

    ---------- Post added at 06:12 PM ---------- Previous post was at 06:08 PM ----------

    Wed Jan 07 18:10:20 2015: pf_init C:\ProgramData\Adguard\NetworkTemp
    Wed Jan 07 18:10:28 2015: Proxy::tcpConnected() id=66321
    Wed Jan 07 18:10:28 2015: tcpConnected id=66321 flag=2 pid=12392 direction=out local=192.168.1.115:50765 remote=54.225.90.95:80
    Process: C:\Program Files (x86)\ASUSTOR\Control Center\LiveUpdate.exe

    Wed Jan 07 18:10:29 2015: Proxy::tcpClosed() id=66321

    WAS RESET ATTEMPTED TO LOG ONTO ASUSTOR BLOCKED.

    ---------- Post added at 06:16 PM ---------- Previous post was at 06:12 PM ----------

    Wed Jan 07 18:12:44 2015: pf_init C:\ProgramData\Adguard\NetworkTemp

    Attempted to print this line item was added in the log file. Once I disabled adguard I could print just fine.

    ---------- Post added at 06:18 PM ---------- Previous post was at 06:16 PM ----------

    Wed Jan 07 18:12:44 2015: pf_init C:\ProgramData\Adguard\NetworkTemp ---------> HP Photosmart Printer

    Wed Jan 07 18:10:28 2015: tcpConnected id=66321 flag=2 pid=12392 direction=out local=192.168.1.115:50765 remote=54.225.90.95:80
    Process: C:\Program Files (x86)\ASUSTOR\Control Center\LiveUpdate.exe --------> Asustor NAS Server

    I need these two items to work or I'll need a refund. They used to work until your last update. I cannot make it more clear than this.

    ---------- Post added at 07:04 PM ---------- Previous post was at 06:18 PM ----------

    Wed Jan 07 18:10:28 2015: tcpConnected id=66321 flag=2 pid=12392 direction=out local=192.168.1.115:50765 remote=54.225.90.95:80
    Process: C:\Program Files (x86)\ASUSTOR\Control Center\LiveUpdate.exe <--------- Asustor NAS Control Center

    Wed Jan 07 18:12:44 2015: pf_init C:\ProgramData\Adguard\NetworkTemp <------- HP Photosmart 6510 Printer
     
  12. Dolfi

    Dolfi Banned

    Joined:
    Nov 21, 2014
    Messages:
    218
    As you know I am no AG worker but it's hard for anyone to help you if you do not follow best practices and/or directions but post random snippets.

    At least that was "best practices". BTW: 7Zip compresses 98MB log file to a <5MB 7z-file.
    And once again: LiveUpdate (as the name suggests(!)) <> ACC. ACC was very poorly coded if it malfunctioned bc of a malfunctioning update process (i.e. offline machine, dead update server).
    I also very much doubt "C:\ProgramData\Adguard\NetworkTemp ---------> HP Photosmart Printer". You just jump to (IMHO wrong) conclusions, that way avatar cannot do too much.

    P.S. As you insist the old version had worked: Here (AdGuard.5.10.1167.5997.setup.exe - ~24.11.2014) or here (AdGuard.5.10.1183.6160.setup.exe - ~22.12.2014) you go.
     
  13. Arniceous

    Arniceous New Member

    Joined:
    Jan 2, 2015
    Messages:
    8
    I have pm'ed avatar thanks for your response, however; basic users couldn't even begin to troubleshoot this so lets not go there again I would appreciate that. You actually were attacking me!

    The line coded for the printer is: C:\ProgramData\Adguard\NetworkTemp

    I deleted the log files there hasn't been anything extra this I tried to print and its been disabled. Also poor coding or not from either party is not out concern either. If we cant use it soon we will call our bank and explain our situation. And also reverting to an older version with no updates on a lifetime membership is also no the answer falling behind with definition updates. Here is another random snippet of everything in the log with an additional second attempt to print than turend the utility back off and printed fine.

    Wed Jan 07 18:10:20 2015: pf_init C:\ProgramData\Adguard\NetworkTemp
    Wed Jan 07 18:10:28 2015: Proxy::tcpConnected() id=66321
    Wed Jan 07 18:10:28 2015: tcpConnected id=66321 flag=2 pid=12392 direction=out local=192.168.1.115:50765 remote=54.225.90.95:80
    Process: C:\Program Files (x86)\ASUSTOR\Control Center\LiveUpdate.exe

    Wed Jan 07 18:10:29 2015: Proxy::tcpClosed() id=66321
    Wed Jan 07 18:12:44 2015: pf_init C:\ProgramData\Adguard\NetworkTemp

    Thu Jan 08 07:33:09 2015: pf_init C:\ProgramData\Adguard\NetworkTemp
     
    Last edited by a moderator: Jan 8, 2015
  14. Dolfi

    Dolfi Banned

    Joined:
    Nov 21, 2014
    Messages:
    218
    I'm sorry you feel offended by open words.
    I am no AG worker but a 3rd level supporter for another company, so what I write is from troubleshooting experience. Also I offered you 2 workarounds (proxy mode, 2 past versions).
    I'm sorry too that you appear to 'know it better' though. Nevertheless, I'll leave it to avatar (see here though).


    Regards, Dolfi
     
  15. Arniceous

    Arniceous New Member

    Joined:
    Jan 2, 2015
    Messages:
    8
    hey no cat and mouse fights please im just showing the log file and explaining what I do as an entry is made. I don't no about proxy settings within the program but my NAS server and Printer are not using php nor html so I don't know what you mean about a proxy server setting going to help but I do see connection choices in the program I figured it was for updating the utility.

    I hope Avatar can work this one, cause we really liked the program.
     
  16. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Hi @Arniceous,

    I need full log file to troubleshoot. Could you please upload it to some file storage (dropbox/mega/gdrive/etc) and PM me a link?

    Also you may downgrade to previous stable version until we fix this issue:
    https://static.adguard.com/5/setup-5.10.1167.5997.msi

    To downgrade:
    1. Uninstall current version
    2. Run cmd as administrator
    3. Run the msi file from cmd
     
  17. Arniceous

    Arniceous New Member

    Joined:
    Jan 2, 2015
    Messages:
    8
    sorry I deleted the log file it was 98Mb and took notepad quite a while to open. So It was best if I dumped it and just tried those programs I mentioned exclusively. So there would be nothing els to fish through.
     
  18. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,135
    Have you tried downgrading to the previous version?

    If not could you please collect logs one more time? Sorry for this, next week when our team will return from these long vacation we'll try to reproduce this bug on our side, but right now I just can't do it by myself.
     
  19. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,902
    New beta version for Windows is released (5.10.1198.6223) where the compatibility problem with Adguard and Asus Control Center is fixed. You can update and try it now.