Twitter and Facebook embed

Roccobot

New Member
I'm using some anti-social annoyances which I really enjoy, BUT I'd like to see embedded tweets and Instagram posts in pages. Example: this page has a Twitter widget and I see it like this.

Any suggestion for a proper whitelist rule?

Thanks
 

Blaz

Moderator & Translator
Staff member
Moderator
If your filter works on url base, add these rules to your user filter for twitter:
Code:
@@||platform.twitter.com/css/tweet
@@||platform.twitter.com/widgets.js
@@||platform.twitter.com/js/tweet
@@||platform.twitter.com/js/grid~moment~timeline~tweet
@@||platform.twitter.com/js/moment~timeline~tweet
@@||platform.twitter.com/widgets/widget_iframe
For facebook/instagram I need some site.
 

Blaz

Moderator & Translator
Staff member
Moderator
Please post that anti social filter, else it is guess work.
 

Roccobot

New Member
Please post that anti social filter, else it is guess work.
Oh, sorry, you're perfectly right. I'm using Adguard for Mac and these are the filter that most likely prevent those embeds to show correctly (the list shows up in Italian, sorry):



 

Blaz

Moderator & Translator
Staff member
Moderator
Working fine here with mentioned filter lists. Please note you don't need Fanboy's Social Blocking List if you have enabled Fanboy's Annoyances.
Please check filtering log and search for twitter.com and post what is blocked there.
 

Roccobot

New Member
Working fine here with mentioned filter lists. Please note you don't need Fanboy's Social Blocking List if you have enabled Fanboy's Annoyances.
Please check filtering log and search for twitter.com and post what is blocked there.
Found the log: with the filters listed above, plus the rules you already suggested, this is what I see.
I double clicked every blocked element and everything appears to be blocked by the Anti-Spyware list.
 

Blaz

Moderator & Translator
Staff member
Moderator
Then it is no url block.

Try this rule:

@@||theverge.com^$generichide

Sadly I only have Windows and mobile devices, so can not check on Mac. @TheHasagi please check on Mac with given filters.
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@Roccobot

Hello!

Looks fine to me, no unloaded pictures on this website, what happens if you disable filtration for the whole website? (Click on the assistant icon at the right bottom corner - Disable filtering for this website)
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@Roccobot

Can you now try to disable all filters but Base (English) and try again? (Before you do, on that webpage F12 - click RMB on the refresh icon then click on "clear cache" and refresh the page)
 

Roccobot

New Member
@Roccobot

Can you now try to disable all filters but Base (English) and try again? (Before you do, on that webpage F12 - click RMB on the refresh icon then click on "clear cache" and refresh the page)
Actually it was still not working, but the page looked the right way in Incognito mode. Could it mean it is some extension that is messing with the Twitter widget?
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@Roccobot

Well, now try to enable other filters one by one till the "guilty" one is detected:)
 

TheHasagi

Quality Assurance / Support Commando
Staff member
Administrator
Moderator
@Roccobot

No, I don't think so, because it's impossible to reproduce for me and for @Blaz. MacOS/Win/Android/iOS this page looks fine. What other extensions do you have onboard with Chrome?
 
Top