Twitter and Facebook embed

Discussion in 'Custom Filters' started by Roccobot, Dec 10, 2018.

  1. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    I'm using some anti-social annoyances which I really enjoy, BUT I'd like to see embedded tweets and Instagram posts in pages. Example: this page has a Twitter widget and I see it like this.

    Any suggestion for a proper whitelist rule?

    Thanks
     
  2. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,651
    If your filter works on url base, add these rules to your user filter for twitter:
    Code:
    @@||platform.twitter.com/css/tweet
    @@||platform.twitter.com/widgets.js
    @@||platform.twitter.com/js/tweet
    @@||platform.twitter.com/js/grid~moment~timeline~tweet
    @@||platform.twitter.com/js/moment~timeline~tweet
    @@||platform.twitter.com/widgets/widget_iframe
    
    For facebook/instagram I need some site.
     
  3. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    Thanks a lot! Anyway I still see the page the same way :oops:
     
  4. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,651
    Please post that anti social filter, else it is guess work.
     
  5. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    Oh, sorry, you're perfectly right. I'm using Adguard for Mac and these are the filter that most likely prevent those embeds to show correctly (the list shows up in Italian, sorry):



    [​IMG]
     
  6. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,651
    Working fine here with mentioned filter lists. Please note you don't need Fanboy's Social Blocking List if you have enabled Fanboy's Annoyances.
    Please check filtering log and search for twitter.com and post what is blocked there.
     
  7. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    I don't know how to enable logging on Adguard for Mac :(

    Could my whole list of active filters help here?
     
  8. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    Found the log: with the filters listed above, plus the rules you already suggested, this is what I see.
    I double clicked every blocked element and everything appears to be blocked by the Anti-Spyware list.
     
  9. Blaz

    Blaz Moderator & Translator Staff Member Moderator

    Joined:
    Dec 21, 2014
    Messages:
    9,651
    Then it is no url block.

    Try this rule:

    @@||theverge.com^$generichide

    Sadly I only have Windows and mobile devices, so can not check on Mac. @TheHasagi please check on Mac with given filters.
     
  10. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    Thank you again, but unfortunately it is still not working
     
  11. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,395
    @Roccobot

    Hello!

    Looks fine to me, no unloaded pictures on this website, what happens if you disable filtration for the whole website? (Click on the assistant icon at the right bottom corner - Disable filtering for this website)
     
  12. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    Good idea and there's actually something weird going on: even with an exception for the whole domain my problem remains the same
     
  13. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,395
  14. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    Chrome 71, the only one which I apply Adguard filtering. I use Firefox and Safari for work and I have no extensions or stuff on them, so of course I see the page correctly with both.
     
  15. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,395
    @Roccobot

    Can you now try to disable all filters but Base (English) and try again? (Before you do, on that webpage F12 - click RMB on the refresh icon then click on "clear cache" and refresh the page)
     
  16. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    Yes, it works this way.
     
  17. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40
    Actually it was still not working, but the page looked the right way in Incognito mode. Could it mean it is some extension that is messing with the Twitter widget?
     
  18. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,395
    @Roccobot

    Well, now try to enable other filters one by one till the "guilty" one is detected:)
     
  19. TheHasagi

    TheHasagi Quality Assurance / Support Commando Staff Member Administrator Moderator

    Joined:
    Mar 26, 2018
    Messages:
    1,395
    @Roccobot

    No, I don't think so, because it's impossible to reproduce for me and for @Blaz. MacOS/Win/Android/iOS this page looks fine. What other extensions do you have onboard with Chrome?
     
  20. Roccobot

    Roccobot New Member

    Joined:
    Jul 25, 2017
    Messages:
    40