Twitter registration nag screen

OleF

Beta Tester
Hi there, when you open a twitter page, before you can see the actual page you have to click away a grey screen with a white invitation to register and open an account. This is not an ad, but it is bothersome nonetheless.

Is there a rule I could add to my user list that would make it disappear? I am using the Avant browser, version 2014 build 7, on Windows 7 Ultimate SP1.

Thanks!
 

Ligre

Member
Мне тоже был бы полезен данный фильтр :)

При заходе на любую страницу, ну например, на https://twitter.com/salt1s
появляется вот это, плюс блокировка страницы за границами блока. Можно закрыть и больше не появляется, но если удалить куки то все как в первый раз.
View attachment 1397
 

avatar

Administrator
Staff member
Administrator
I see. Add this rule to your user filter:
Code:
twitter.com###signup-dialog
 

Ligre

Member
avatar
Этого мало будет, так как блокируется и выцветает экран. Правило помогает лишь от окна.
 

OleF

Beta Tester
Wow, you guys are awesome, thanks for the blistering fast reply! :)

Indeed the registration field went away, but the grey screen did not. However, I now managed to make it disappear with the AdGuard Assistant, after which the following line was added to my user rules:

twitter.com##DIV.modal-overlay:nth-child(7)

Thanks again, now finally I can eliminate all useless elements from the websites I use!!!
 

avatar

Administrator
Staff member
Administrator
Final set of rules:
Code:
twitter.com###signup-dialog
twitter.com##.modal-overlay
 

OleF

Beta Tester
Actually the solution is not perfect, as together with the grey layer the scroll bar on the right side of the window also disappears, which makes it impossible to move down the page, even using Pageup and -down.
 

avatar

Administrator
Staff member
Administrator
We need one more rule then.

Code:
twitter.com###signup-dialog
twitter.com##.modal-overlay
twitter.com#$#.modal-enabled { position: inherit!important; overflow: inherit!important; }
 

OleF

Beta Tester
That doesn't seem to really work, the scroll bar is still missing. It shows briefly, like for a second, after the page is loaded, and then disappears.
 
Last edited by a moderator:

avatar

Administrator
Staff member
Administrator
Which browser do you uses? I've tested in Chrome, everything is ok.
 

OleF

Beta Tester
I use Windows 7 Ultimate SP1 64-bit, Avant 2014 Build 7, Bitdefender Free.

You guys really offer excellent support, no SW I have never purchased has come even close :)

---------- Post added at 11:32 AM ---------- Previous post was at 11:28 AM ----------

I admit that I have stripped the twitter page of all (for me) useless elements, maybe the problem lies in there. I don't want you to waste your time for a problem that I maybe caused myself, let me disable my user rules for twitter and check with yours, then I will come back to you. I have some other stuff to do now, so give me a couple of hours to do that, and I will report back.
 

avatar

Administrator
Staff member
Administrator
Which version of Adguard do you use?
I've tested these rules with Adguard 5.10.
 

OleF

Beta Tester
5.10.1156.5925, just registered my licence

---------- Post added at 11:45 AM ---------- Previous post was at 11:42 AM ----------

However, I just tested the twitter page with my personal user rules disabled, and the scroll bar does still disappear.
 

OleF

Beta Tester
The problem happens with Twitter both with IE Standard and IE Compatible. What I do note is that at first a) the letters on the page are crisp and b) the scroll bar is there, then, after approximately one second, the letters become "thinner" and a bit blurred, and in the same moment the scroll bar disappears.

I tried to open Twitter on Maxthon 4.4.1.5000, upon opening the website showed as it is supposed to do. Then I disabled Maxthon's AdHunter for the page, and the characters also turned hazy, although the scroll bar remains. After enabling AdHunter again, the characters did first load crisp, then after a second not back to blurry.

On FF 32.0 instead Twitter is shown correctly, with crisp characters, my user rules applied and the scroll bar shown.
 
Last edited by a moderator:

Ligre

Member
We need one more rule then.

Code:
twitter.com###signup-dialog
twitter.com##.modal-overlay
twitter.com#$#.modal-enabled { position: inherit!important; overflow: inherit!important; }
Chrome + Расширение, все отлично.
Спасибо!
 

avatar

Administrator
Staff member
Administrator
The problem happens with Twitter both with IE Standard and IE Compatible. What I do note is that at first a) the letters on the page are crisp and b) the scroll bar is there, then, after approximately one second, the letters become "thinner" and a bit blurred, and in the same moment the scroll bar disappears.

I tried to open Twitter on Maxthon 4.4.1.5000, upon opening the website showed as it is supposed to do. Then I disabled Maxthon's AdHunter for the page, and the characters also turned hazy, although the scroll bar remains. After enabling AdHunter again, the characters did first load crisp, then after a second not back to blurry.

On FF 32.0 instead Twitter is shown correctly, with crisp characters, my user rules applied and the scroll bar shown.
I've tested these rules with IE11 and everything was good.

What version of IE you have? Avant and Maxthon both use IE for rendering.
 

OleF

Beta Tester
Hi there, after an afternoon and half a night of searching and experimenting I have managed to eliminate the problem. Looks like it was caused - across all browser platforms - by Windows Update KB2670838, which is required for the use of IExplorer 10 and 11. I disinstalled it, which automatically disinstalled IExplorer 11 as well (!), and installed IExplorer 9 for Windows 7 64-bit instead. Since then the fonts in all the browsers I use (FF, Iexplorer, Avant and Maxthon) not only on Twitter but on all websites are rendered perfectly crisp and well readable.

Windows Update proposed this update again this morning, together with IExplorer 10 and 11. I hid all of these updates from Windows Update, as KB2670838 is integrated into the two updates for IExplorer, but will not show in the disinstallable updates after installation.

After these changes, running Avant with "IE standards" rendering and activating "filter https protocol", the three rules you have proposed do block the Twitter nag screen upon opening the page work perfectly, with the scroll bar visible and working. Thank you very much! :)

Yet although the AdGuard icon *does* show at the bottom right of Twitter, now the user window used to block items does not pop up anymore, and on some sites like zerohedge.com the icon doesn't show at all (which in the ce case of zerohedge.com it didn't even before the changes I made). Is there anything that can be done about that?
 

Boo Berry

Moderator + Beta Tester
Moderator
Yet although the AdGuard icon *does* show at the bottom right of Twitter, now the user window used to block items does not pop up anymore, and on some sites like zerohedge.com the icon doesn't show at all (which in the ce case of zerohedge.com it didn't even before the changes I made). Is there anything that can be done about that?
Disable the Adguard Assistant.
 
Top