[-] Umbra's Feedbacks [AdGuard Mobile]

Discussion in 'Discussion (Beta Versions)' started by Umbra, Oct 26, 2015.

  1. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,892
    @Umbra

    We've tested on the latest beta and couldn't reproduce it (messages are not received and status is 'offline'). I have 3 suggestions:

    1) You haven't restarted the protection after disabling connection for Viber;
    2) You haven't restarted Viber on the other phone (after I did it, the status for the account with Adguard-blocked Viber was 'offline');
    3) The problem exists in older beta but not in the latest one. It is worth updating to it (2.8.58) and trying again.
     
  2. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    ok will update and check
     
  3. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    ok updated to build 58 ,and found out the reason, i disabled viber's connections while Adguard was turned OFF, then turned it ON; seems it must be done while AdG is ON then restart it as you said..
     
    Last edited: Nov 25, 2016
  4. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,892
    @Umbra Interesting, I actually don't know if it is an expected behavior. I will consult the developer and reply back to you later.
     
    Umbra likes this.
  5. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    updated to build .71 no issues so far.
     
  6. vasily_bagirov

    vasily_bagirov Administrator Staff Member Administrator

    Joined:
    Jul 1, 2014
    Messages:
    6,892
    Thanks! Actually, there were some pretty major problems, and that's why we fired the .76 hotfix :)
     
  7. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    i see , updated to .76 , still no issue.

    However on .71 (didn't tried yet on .76) and about the viber/firewall thingy.

    i observed that behavior:

    0- modify Adguard FW rule to block Viber to access networks

    then

    1- launch viber
    2- launch & activate Adguard
    3- Viber isn't blocked to access networks.

    but if:

    1- launch Viber
    2- launch & activate Adguard
    3- close Viber from Task Manager
    4- relaunch Viber
    5- then Viber is blocked .

    So my conclusion is that the FW doesn't consider any already opened apps. One must be closed before activating Adguard to obtain the desired FW effect.
     
    Last edited: Dec 10, 2016
  8. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    update:

    im not using an android phone anymore; now im on a Windows Phone (Win10), there is a chance to have a Windows Mobile version of Adguard? (i know the market is very small ^^ )
     
  9. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,648
  10. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,121
    There are some problems with the planned WinMobile.

    It appeared, that those APIs we were planning to use for ad blocking, simply do not work in the Anniversary update.
    There's a hope they'll fix it in the next major Windows update, though.
     
  11. Boo Berry

    Boo Berry Moderator + Beta Tester Moderator

    Joined:
    May 30, 2012
    Messages:
    3,648
    Have you tried any of the Insider Previews for mobile to see if they've fixed it for the Creator's Update coming in April?
     
  12. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,121
    You wouldn't believe what a pain is to use Insider Preview for mobile. Last time we've almost bricked the test device:(

    I can say that it was not fixed in December.
     
  13. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    just bought a new Android phone using Nougat v7 , using latest beta , no issues so far.
     
  14. avatar

    avatar Administrator Staff Member Administrator

    Joined:
    Oct 26, 2010
    Messages:
    13,121
    Congrats on the new phone btw:)
     
  15. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    Thanks, it is a Huawei GR5 Pro 2017 (aka Honor 6X) , mine is the 4Gb RAM & 64 Gb storage version, quite powerful for a medium-end device :D
     
  16. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    Installed Adguard for Android on my Xperia XA1 Ultra; no issue so far, i like the DNScrypt option.
     
  17. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    Using AdG for Android v2.11.81; no issues so far.
     
    avatar likes this.
  18. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    Using nightly build. 2.12
     
  19. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    AdG crashes once i tried to enable it.

    @vasily_bagirov @avatar can i have your email to send you the logs?
     
    Last edited: Jun 15, 2018
  20. Umbra

    Umbra Beta Tester

    Joined:
    Oct 23, 2015
    Messages:
    71
    installed v2.12.140, no issues so far.