[-] Umbra's Feedbacks [AdGuard Mobile]

vasily_bagirov

Administrator
Staff member
Administrator
@Umbra

We've tested on the latest beta and couldn't reproduce it (messages are not received and status is 'offline'). I have 3 suggestions:

1) You haven't restarted the protection after disabling connection for Viber;
2) You haven't restarted Viber on the other phone (after I did it, the status for the account with Adguard-blocked Viber was 'offline');
3) The problem exists in older beta but not in the latest one. It is worth updating to it (2.8.58) and trying again.
 

Umbra

Beta Tester
ok updated to build 58 ,and found out the reason, i disabled viber's connections while Adguard was turned OFF, then turned it ON; seems it must be done while AdG is ON then restart it as you said..
 
Last edited:

vasily_bagirov

Administrator
Staff member
Administrator
Thanks! Actually, there were some pretty major problems, and that's why we fired the .76 hotfix :)
 

Umbra

Beta Tester
i see , updated to .76 , still no issue.

However on .71 (didn't tried yet on .76) and about the viber/firewall thingy.

i observed that behavior:

0- modify Adguard FW rule to block Viber to access networks

then

1- launch viber
2- launch & activate Adguard
3- Viber isn't blocked to access networks.

but if:

1- launch Viber
2- launch & activate Adguard
3- close Viber from Task Manager
4- relaunch Viber
5- then Viber is blocked .

So my conclusion is that the FW doesn't consider any already opened apps. One must be closed before activating Adguard to obtain the desired FW effect.
 
Last edited:

Umbra

Beta Tester
update:

im not using an android phone anymore; now im on a Windows Phone (Win10), there is a chance to have a Windows Mobile version of Adguard? (i know the market is very small ^^ )
 

avatar

Administrator
Staff member
Administrator
There are some problems with the planned WinMobile.

It appeared, that those APIs we were planning to use for ad blocking, simply do not work in the Anniversary update.
There's a hope they'll fix it in the next major Windows update, though.
 

Boo Berry

Moderator + Beta Tester
Moderator
There are some problems with the planned WinMobile.

It appeared, that those APIs we were planning to use for ad blocking, simply do not work in the Anniversary update.
There's a hope they'll fix it in the next major Windows update, though.
Have you tried any of the Insider Previews for mobile to see if they've fixed it for the Creator's Update coming in April?
 

avatar

Administrator
Staff member
Administrator
Have you tried any of the Insider Previews for mobile to see if they've fixed it for the Creator's Update coming in April?
You wouldn't believe what a pain is to use Insider Preview for mobile. Last time we've almost bricked the test device:(

I can say that it was not fixed in December.
 

Umbra

Beta Tester
Installed Adguard for Android on my Xperia XA1 Ultra; no issue so far, i like the DNScrypt option.
 
Top