Unable to Block an Element on YTS.am

DSNeed

New Member
I'm trying to block the VPN ad on YTS.am (see the screenshot below). According to Adguard itself, the string to filter is yts.am##.aibox-bordered, but it never works. Also, often times the Adguard button, usually at the bottom right, disappears.

 

DSNeed

New Member
It initially works for me, but I hit refresh and it’s back.

I’m wondering if one of the other filters is causing an issue. Other than the User List, I have the following filters active:

AdGuard Base Filter
AdGuard Tracking Protection filter
Adblock Warning Removal List
Malware Domains
Spam404
NoCoin Filter List

I’m open to recommendations to remove and add filters.
 

Blaz

Moderator & Translator
Staff member
Moderator
Working fine here:
Code:
yts.am##.bottom-info > div[class] > .aibox-bordered
yts.am##.nbox-bordered
When Assistant vanishes, try to reinstall SSL certificate.
 

DSNeed

New Member
I've tried your suggestions, but still can't get it to work in Chrome or Firefox. It seems to be the only page that won't work. All other elements are being blocked on other pages.
 

Blaz

Moderator & Translator
Staff member
Moderator
When it is not blocked, please right click on element -> inspect element and check if you see something like "display: block!important;" for its style.
 

DSNeed

New Member
Here's the code from the element.

<div class="aibox-bordered" style="width: 100%; height: 148px; margin: 0px; padding: 10px 12px; border:1px solid #75C74E;border-radius: 4px;position: relative;background: #000000;">
<div class="title" style="font-size: 10px;width: 100%;margin-bottom: -15px;border: 0px;">
<h1 style="font-size: 15px;line-height: initial;text-align: left;">Please enable your VPN when downloading torrents</h1>
</div>
<p class="blue" style="color:#ABCC06;text-align: justify;margin-top: 10px;font-size: 13px;line-height: 20px;">
Assigned IP address <span style="background:#AD0000; color: white;"></span>, located in <span style="background:#AD0000; color: white;"></span>.
Your ISP can monitor you, unless you use a zero log VPN.
</p>
<a href="/pro-ws" class="vpn-link" rel="noindex, nofollow">
<div class="button" style="width: 208px;">
<img src="/images/download.png">
<p style="margin-top: -10px;font-size: 15px;">Get Windscribe VPN</p>
</div>
</a>
</div>
 
Last edited by a moderator:

Blaz

Moderator & Translator
Staff member
Moderator
I was talking about the red marked area (can be also at another position for you). The code itself is not helping.

If that display:block!important is there set (if position is also set with !important, then not working), try this rule:
Code:
yts.am#$#.bottom-info > div[class] > .aibox-bordered { position: absolute!important; left: -6000px!important; }
 

Attachments

Blaz

Moderator & Translator
Staff member
Moderator
Is the site in whitelist? Did you try to remove user filter and then add the first rule.
What is the element showing for it's style (marked in my last screenshot)?
 

DSNeed

New Member
Deleted all the YTS.am rules and re-added the aibox.bordered rule. Still no go. Below is the Style info.

 

Blaz

Moderator & Translator
Staff member
Moderator
Please scroll down right side and post screenshots of those.

But we can also use Teamviewer, so I can take a look at it. Just PM me ID and password and your online time and timezone.
 

Blaz

Moderator & Translator
Staff member
Moderator
Nothing indicates an issue in style. What is filtering log saying when you open the site?
 

Blaz

Moderator & Translator
Staff member
Moderator
AdGuard for Windows does not show elemhide rules in filtering log, Extension does.
Please try to reinstall AdGuard for Windows.
 

DSNeed

New Member
Finally got around to reinstalling. I first used the Uninstall tool to completely remove AdGuard and reinstalled v.7.0.2693.6661. Still having the same problem.
 
Top